ASRock P55 Deluxe, Sata 6Gb/s card & SSD system drive, and NCQ woes

I just got myself the ASRock P55 Deluxe motherboard that comes with a Sata 6Gb/s add-on card. I also got a Kingston SSDNow V-Series 128 GB that I want to use as my system drive.

When I plug the SSD into the standard Sata 3Gb/s connections on the motherboard Windows setup sees that I have the SSD and has allowed me to install to it. If I try to plug the SSD into the Sata 6Gb/s add-on card Windows setup does NOT see that I have a hard drive hooked up.

Is it not possible to use that add-on card in conjunction with a SSD as a system drive? I figured there might be some sort of performance benefit to going that route, but I can't seem to make it work. I don't know if I'm setting up something in the BIOS wrong or what.

Also related to all this, when I boot Windows up using the standard Sata connection with the SSD the Windows Performance Index rated the SSD as 5.9 which seemed a bit low. So as I was digging around in settings I noticed that NCQ is disabled. It was to my understanding that SSDs hooked up using SATA and AHCI use NCQ for further performance increase. I have it set in BIOS to use AHCI but can't figure out how to enable NCQ.

But just to add to the confusion I also recently read a post somewhere stating that when using an SSD for a system drive that you don't want to use AHCI in BIOS but instead use IDE. But wouldn't that also keep the SSD from using NCQ? So what's the deal?

I'm a bit clueless when it comes to the finer details of IDE, SATA, AHCI, and NCQ, so hopefully someone can help me clear these muddy waters up.

1. For a SSD system drive do I set it up in BIOS to be IDE or AHCI? And there are lots of SATA switches that can be set as AHCI or other, so which ones or just all of them?

2. Is it possible to have the SSD system drive connected through the Sata 6Gb/s add-on card? If so, what do I need to set in BIOS in order for Windows set-up or even the already installed OS to recognize that the SSD exists and is actually the boot drive?

3. How do I enable NCQ on the SSD? Or is it better to not use NCQ?

In the simplest form I just want to make sure that I'm able to use this SSD as the system drive using the best performing options.
11 answers Last reply
More about asrock deluxe sata card system drive woes
  1. Is you add-on card bootable?

    Why would you need NCQ with an SSD? It has no moving parts; therefore it can't help. An SSD should perform about the same when the controller is set for IDE, AHCI or RAID.

    What OS? If Vista, then the maximum performance index is 5.9.
  2. Hi, thanks for replying!

    I'm not sure if the add-on card is bootable or not. The motherboard doesn't really give any detailed information about it except that it's to be installed in a PCI-E slot and that it provides 2 internal SATA 6Gb/s connections.

    If you Google NCQ and SSD there are TONS of discussions that make it seem like NCQ and SSDs go together like peanut-butter and jelly. I can only assume that it's good to have NCQ enabled when there are so many discussions and articles connecting the two together.

    And sorry forgot to mention I'm using Windows 7 64-bit.
  3. What add-on card did you buy?

    NCQ is useless unless the drive has moving parts. As far as I'm concerned, SSD units don't have read/write heads.

    Is the performance acceptable?
  4. Hi GhislainG, thanks for the replies.

    As far as NCQ goes every article I've read suggests that SSDs do benefit from the queuing of data from NCQ. It's not about the moving parts but the actual ordering of data. Although I'm sure standard hard drives probably benefit much more because of the decrease in moving of the heads.

    The add-on card came with the ASRock P55 Deluxe motherboard and is a Marvell card. That's all I know about it. The motherboard doesn't come with any information about the card other than "plug it into a PCI-E slot". It also instructs to install a Marvell 6G driver, which just so happens to bomb out when trying to install.

    Windows also seems to lock up when I try to update any of the Sata 3G drivers on the board, as well as the Marvell 6G. So as of now I'm just going to give up.

    Your last question is the key. Is the performance acceptable? Sure, it's better than my old system, so I'm just going to resign to being happy with that and try to ignore my OCDness about expecting things to work the way they're supposed too.. hehe.

    Maybe some day ASRock's technical support will actually reply to my e-mail I sent them and they can help me figure out why I can't install drivers relating to the add-on card or the board's own SATA drivers.

    Thanks again!
  5. The SATA add-on card should be bootable. Is the SSD visible on the Marvell controller and can it be selected as the primary boot device?
  6. Well when I connect it to the card I can't boot from it, or even try to install Windows 7 to it. Windows simply doesn't notice it's there.

    I haven't tried hooking up a second drive to it yet besides my boot drive. I'll have to try that after work just to see if the thing even works. If it doesn't see my storage drive when hooked up to the card I guess that'll tell me the card is hosed or the drivers ASRock provided are bad.

    As it is now it's just one of those things... poking me and taunting me. It's there. It's plugged in. It should work. It doesn't. How dare it thwart my will!
  7. If you want to use NCQ and TRIM, then you need to install in AHCI mode. Check and Verify this was done (I suspect the answer here is 'no')


    It is possible to enable AHCI after the fact... If you want to....


    BACK UP YO SHEEYAT!!!

    THIS INVOLVES REGISTRY SETTINGS!!

    THE ONLY ONE RESPONSIBLE IF YOU DO THIS IS YOU!

    MAKE A SYSTEM RESTORE!!

    IT'S THE RED PILL!!! OR WAS IT THE BLUE?? No... Wait....


    http://www.sevenforums.com/tutorials/61869-ahci-enable-windows-7-vista.html?ltr=A
  8. Actually that is how I had the BIOS set up when I originally installed Windows 7. That's why I was confused that NCQ was showing to be disabled. I assumed that if I had the BIOS set up as AHCI when I installed Windows 7 that it would automatically be set up to have NCQ enabled.

    I wonder if this is a driver or maybe even a BIOS issue. I think this weekend I'll try updating the BIOS first to see if that makes a difference.

    As far as drivers go I tried installing the Marvell 6G drivers that are included on the motherboard's setup disc, as well as the ones provided on their website while in Windows 7 installation. I got failure messages or no recognized driver messages no matter what I tried.

    Trying to install them after Windows has been installed would lead to a BSOD.

    Their download site is kind of confusing too. For the P55 Deluxe they have 5 different related drivers.

    1. SATA RAID Driver (For system to read from floppy diskette during Windows installation)
    2. Marvell SATA3.0 Floppy Image ver:1.0.0.1027
    3. JMicron SATA2 driver ver:R1.17.52.02
    4. Marvell SATA3 driver ver:1.0.00.1027
    5. SATA2 (AHCI) driver ver:9.5.0.1037

    They have no description or instructions for these except that trying to install the 4th one from Windows tells you to go to device manager to update the "Standard 1.0 AHCI Controller" driver or something like that. Doing so gives mixed results.

    In experimenting with the various drivers listed above I've either gotten BSOD, failed to install messages, disappearing DVD drives, or Windows is no longer able to boot after installation.

    Very frustrating. If I do no driver updates the system seems to be stable and runs fine. It's just that nagging feeling of knowing there are supposedly "updated" drivers available but not being able to use them. But considering the headaches trying to install them provides I'm leaning towards the "if it ain't broke, don't fix it" mentality. I've just never had a computer I've built beat me before.. lol.
  9. Hmmmm... Poking around, I found:

    http://www.nordichardware.com/en/news/86-storage/269-kingston-ssdnow-v-and-jmicron-jmf61-controller-tested.html

    It looks like your drive may not support NCQ...
  10. That may have been based on the older version. Here's the one I got, and in the specs it mentions NCQ.

    http://www.newegg.com/Product/Product.aspx?Item=N82E16820139136
  11. Hmm, according to TweakTown's review of this motherboard (http://www.tweaktown.com/articles/2991/sata_6g_implementation_preview_ironing_out_the_creases/index.html) they say that the 6G add-on card actually uses up lanes of the PCI-E graphics pool. So it'd drop my x16 graphics card down to x8.

    Well forget that then! I'm just going to ignore the add-on.. lol.

    Now I just need to figure out why I'm not seeing NCQ enabled on the SSD. I'm guessing bad drivers on the motherboard since when I try updating the Sata 2 drivers all hell seems to break loose.
Ask a new question

Read More

Motherboards SSD SATA ASrock Product