Sign in with
Sign up | Sign in
Your question

BIOS update has 50 file

Last response: in Motherboards
Share
March 17, 2010 1:35:15 PM

Hello,
I tied to update my ASRock Wolfdale 1333 D667 BIOS by downloading the latest BIOS from the Asrock site but the extension of the BIOS file is .50 file. What is a .50 file? I thought it should be a .rom extension. AFUDOS says it can't read the ROM file when I run the utility in DOS mode. What should I do. help!!

More about : bios update file

a b V Motherboard
March 17, 2010 3:23:30 PM

you mean iso perhaps? Burn it to disc and boot to it.
m
0
l
March 27, 2010 12:48:10 AM

No not ISO. I find most of these BIOS updates in DOS mode with .50 file extensions. Since this is an unknown file extension, would like to know what I should do to turn it into a ROM file. The files are found here
http://www.asrock.com/mb/download.asp?Model=Wolfdale133...

Please check them for yourself.
even the modded ones on the internet have a .50 extension. Am I missing something? Help!
m
0
l
Related resources
a c 229 V Motherboard
March 27, 2010 2:00:33 AM

Copy Afudos.exe to a DOS bootable floppy and use it to update the BIOS.
m
0
l
April 2, 2010 1:45:41 AM

I have a bootable floppy and copied both AFUDOS and the WD133D61.50 BIOS file. I typed this on the DOS prompt at bootup :-

C:\\>AFUDOS /iWD133D61.50

and what I got was

cannot read from ROM file.
m
0
l
a c 229 V Motherboard
April 2, 2010 2:24:30 AM

Why do you use AFUDOS /iWD133D61.50 instead of AFUDOS WD133D61.50?
m
0
l
April 3, 2010 3:24:31 AM

because that is the right syntax for AFUDOS. If you type AFUDOS WD133D61.50 it will not even try to flash.

When I type AFUDOS /iWD133D61.50
DOS tells me its flashing and that I should not switch off the computer but then ends by saying that the ROM file could not be read.

My hunch is that something is not right with the .50 file extension for the BIOS file that was downloaded. Prolly it needs an extraction tool or something. Help please anybody.

m
0
l
a c 229 V Motherboard
April 3, 2010 4:13:21 AM

I would download it again from a different site. If it still doesn't work, you should contact ASRock.
m
0
l
April 7, 2010 3:35:25 PM

Hmm guess so!! sigh
m
0
l
April 14, 2010 3:12:32 AM

still no reply form asrock
m
0
l
a c 229 V Motherboard
April 14, 2010 12:06:01 PM

Is there a way to get in touch with them via phone?
m
0
l
April 24, 2010 2:07:13 AM

Called their distributor. They did not answer my call.
m
0
l
a c 229 V Motherboard
April 24, 2010 2:11:04 AM

Then go through your dealer.
m
0
l
May 2, 2010 4:54:33 AM

Same with the dealer. He tried to flash my BIOS with an update of what was already updated using the Windows GUI flash. I stopped him and tried to remind him that I only wanted to know what the .50 file extension is all about for the AFUDOS flash tool and how to get around the problem. Again its a blank. Why did Asrock have this damn .50 file extension for the ROM file in the first place? Its so frustrating.
m
0
l
a c 229 V Motherboard
May 2, 2010 1:09:28 PM

Then all that you can do is flash it from the Windows utility. Just make sure that nothing that could interfere with the flash process is running, e.g., anti-virus, etc.
m
0
l
May 2, 2010 4:55:55 PM

Thats fine but I need to flash it with the modded ver 1.5 BIOS which also has .50 file extension
m
0
l
a c 229 V Motherboard
May 2, 2010 5:59:27 PM

Can't whoever modded the BIOS file tell you how to install it?
m
0
l
!