Sign in with
Sign up | Sign in
Your question
Solved

Audio over HDMI in ATI catalyst

Last response: in Graphics & Displays
Share
October 13, 2009 7:51:44 PM

Hello everyone,

I got this new card 4890 from sapphire and I have to say that I am happy about the gaming performance on my system but I have a problem with the HDMI audio.

I am running a primary monitor plus a secondary HDTV over HDMI in extended desktop modality. First of all the theater option is not really working (I have to manually full screen a window on the extended second monitor).

Secondly and most importantly there is no option to have audio both on the HDMI and analog jack of the motherboard. You have to select manually every time where you want to send the sound from windows control panel sound properties. I think this is really ridiculous and unacceptable from ATI catalyst. If you want to watch a movie you have redirect the sound on the HDMI port, while when you use any other program on the primary screen you don't have sound unless you don't send the sound back to the mobo audio card.

Does anyone face a similar problem and has any idea to figure out a solution?

Thanks :) 
October 13, 2009 9:11:54 PM

The other post is for another system in which I want to set up again a 4890. I personally got a sapphire but I would like to know if any other brand is better (I know the performance can change a lot depending on the manufacturer) and since I had the problem with the audio, maybe someone else can help me to figure it out.

I indeed see the problem. I think the driver should be smart enough to either switch to one source to the other, according if I am using the extended desktop for a video full screen (avi or dvd...) or just working on my standard desktop, or to constantly output the audio to both channel, so at least when you turn off the tv you can still have sound out from the mobo audio card.

Does it make sense?
m
0
l
October 13, 2009 10:01:47 PM

highkftj said:
The other post is for another system in which I want to set up again a 4890. I personally got a sapphire but I would like to know if any other brand is better (I know the performance can change a lot depending on the manufacturer) and since I had the problem with the audio, maybe someone else can help me to figure it out.

I indeed see the problem. I think the driver should be smart enough to either switch to one source to the other, according if I am using the extended desktop for a video full screen (avi or dvd...) or just working on my standard desktop, or to constantly output the audio to both channel, so at least when you turn off the tv you can still have sound out from the mobo audio card.

Does it make sense?


That's weird, I use Cataylst 9.6 and when I extend my desktop it automatically goes to HDMI audio on my TV automatically. Which version are you using? Cataylst 9.9 should be out.

You can't output both audio on your HDMI and mobo audio at the same time because it's an extended desktop. Your computer basically thinks you only have 1 desktop, but you have 2 audio outputs. So you can only output on one of the sources. Well, that's how I see it.

The theater option doesn't go to fullscreen for me either when I extend my desktop, but manually fullscreening a window isn't difficult at all.

None of these are major issues, just be glad it works at all.
m
0
l
Related resources
October 13, 2009 10:13:46 PM

aylafan said:
That's weird, I use Cataylst 9.6 and when I extend my desktop it automatically goes to HDMI audio on my TV automatically. Which version are you using? Cataylst 9.9 should be out.

You can't output both audio on your HDMI and mobo audio at the same time because it's an extended desktop. Your computer basically thinks you only have 1 desktop, but you have 2 audio outputs. So you can only output on one of the sources. Well, that's how I see it.

The theater option doesn't go to fullscreen for me either when I extend my desktop, but manually fullscreening a window isn't difficult at all.

None of these are major issues, just be glad it works at all.



I am glad we have the same issue about the full screen option. I am using catalyst 9.9, last version drivers too. I guess it's a problem with vista64, since a friend has the great xp and no problem, theater mode put automatically full screen the windows on the extension. I agree can be fixed manually just I don't know why it doesn't work properly by itself :) 

For the audio instead no way. unfortunately catalyst doesn't manage audio from its interface so probably is something related to my mobo. Just wanted to see if anyone had similar issue. Again can be solved manually but it's not really what I would like to. I actually think that a lot of this problems are just vista related, and hopefully w7 plus some new drivers can fix them.

Anyway in your configuration, what is the default setting under vista control panel sounds? I have a flag for default playback sound between my analog speakers and the ati HDMI support. what I need to do is anytime move the default setting depending if I want the sound out from the audio video card or from the hdmi port. what setting are you using in this regard?

Thanks
m
0
l

Best solution

October 14, 2009 3:29:11 AM

highkftj said:
I am glad we have the same issue about the full screen option. I am using catalyst 9.9, last version drivers too. I guess it's a problem with vista64, since a friend has the great xp and no problem, theater mode put automatically full screen the windows on the extension. I agree can be fixed manually just I don't know why it doesn't work properly by itself :) 

For the audio instead no way. unfortunately catalyst doesn't manage audio from its interface so probably is something related to my mobo. Just wanted to see if anyone had similar issue. Again can be solved manually but it's not really what I would like to. I actually think that a lot of this problems are just vista related, and hopefully w7 plus some new drivers can fix them.

Anyway in your configuration, what is the default setting under vista control panel sounds? I have a flag for default playback sound between my analog speakers and the ati HDMI support. what I need to do is anytime move the default setting depending if I want the sound out from the audio video card or from the hdmi port. what setting are you using in this regard?

Thanks


I'm using Windows Vista 32bit or x86 with SP2. Under my volume mixer, my default setting under device is "Speakers (Creative SB Audigy 2 WDM)", but when I extend my desktop it gives me a new option & automatically defaults to "ATI HDMI Output (ATI Function Driver for High Definition Audio - ATI AA01)." Before Catalyst 9.6 drivers, I had to manually switch it under the volume mixer. I also think it would be neat to use 2 audio outputs (one from the computer and one from the TV) at the same time, but I don't think Windows Vista has that option yet.
Share
!