Sign in with
Sign up | Sign in
Your question

Troubleshooting: XFX HD 5770 - no image.

Tags:
  • Graphics Cards
  • HD
  • Graphics
Last response: in Graphics & Displays
Share
October 16, 2009 10:40:15 AM

Hello all,

I'm hoping that some can point me in the right direction. I have recently purchased an XFX HD 5770 GPU, but on inserting this into my system I get no picture. I've done the basic troubleshooting and am pretty much at a loss as to where the problem lies. If anyone can make any suggestions then they would be much appreciated - I'm overlooking something and it's bugging me :) 

System:
Mobo: ASRock Alive-Xfire-eSata2 (board has two PCI-E sockets, first socket is plugged with a PCI-E switch card - this socket is labelled so I know that it is the correct one for that).
CPU: AMD 64x2 6000
RAM: Single 2 Gig stick DDRII
PSU: Akasa 450W
All other components removed (hard drive, sound card, CDROM)

Steps tried:
Plugged 5770 into system, connected 2 x molex connectors to the supplied molex/6pin converter and ensured all connections firmly in place. Powered up system - no warning beeps, keyboard responds allowing me to select caps lock on/off, GPU Fan fires up fast then idles after a moment, no picture. Power draw 90W

Plugged 5770 into seperate system - picture comes up fine.

Connected a Radeon HD 3400 to the original system - works fine

Returned 5770 to main system, changed molex connectors - no change.

Tried second PSU (Antec 450W with 6 Pin connector) - no change

Could there be a problem with this motherboard and a 5770? The only thing I can think of is to buy a new mobo but I'd really rather not throw money at this except as a last resort.

Can anyone suggest another line of attack?

More about : troubleshooting xfx 5770 image

October 16, 2009 12:04:49 PM

try one molex from one line and one molex from another, dont plug in two molex from the same line
October 16, 2009 12:04:53 PM

Hi,

maybe you need a bios update.

My girlfriend's Asrock mobo got bios updates to support 3xxx and 4xxxx ati series.

Brad
Related resources
October 16, 2009 12:19:59 PM

Thanks both.

Tried a molex from two different strands, no change. Will check the bios version now and update if below current level
October 16, 2009 1:45:52 PM

Ah well - updated the BIOS to the latest revision (a two year leap), but sadly no improvement.

Thanks for the suggestions, but I'm giving up on this combination now. I'll bag the card until I can get another motherboard.
October 16, 2009 3:14:18 PM

I have this same problem. my card is radeon 4850. and Mobo is: ASROCK AM2 AMD480X DDR2 SATA2 GLAN ATX.
my power supply also is: COMPUCASE PSU 550W 12CM ATX12V2.0


please can anyone give some tips on what to try?

thanks
October 16, 2009 3:27:33 PM

You could try visiting the asrock web site and submit a support request. I just did that, asking if there were any known issues. Can't do any harm.
October 16, 2009 7:20:29 PM

I'm in the same boat. same card as you. Asus A8n32-SLi Deluxe

My PC will not post and the monitor won't come out of standby with the 5770 installed, it's seated properly and the 6pin is in the back. I have a tegan 750W modular supply, i tried the proper 6pin cable and also the converter for two molex connectors coming in from separate lines.

I really have no idea, its runs two 7800GTs in sli perfectly, and just one card.

My only guess is that the psu and pcie 1.0 slot combined just can't put enough power into the card, as i understand the 2.0 has a much higher power output. But the specs are supposed to be interchangeable.

Please any help? there's already a few posts like this around this could potentially be a major problem.

Yes latest bios.
October 16, 2009 7:35:16 PM

ashumuto said:

My only guess is that the psu and pcie 1.0 slot combined just can't put enough power into the card, as i understand the 2.0 has a much higher power output. But the specs are supposed to be interchangeable.


I don't think that this will be the power. The 5770 is meant to idle at 18 watts and max out at around 108. I measured the draw for my system and it was only 90 watts when I powered up. Something definitely seems to be up and since from what you are saying it's not uncommon I would hope that we'll get some official word on the matter soon. Ho hum
October 16, 2009 7:59:25 PM

Well i don't want to point fingers at the card, what's the odds of a faulty card from Scan. Unfortunately the only way to test it is to give it back to scan.
October 16, 2009 9:56:21 PM

In my case the card doesn't appear to be faulty. I tried it in another machine and it worked fine. Also tried another card in my machine which also worked ok, so it looks like for me at least the problem is a combination of the motherboard and GPU in some way. if you have access to another PCI-E machine - friend's etc then that might be worth checking.
October 17, 2009 12:44:18 PM

I also have geforce 7800 LE and it gives no picture either.
i wonder if this problem could be solved by some bios setting? i reset the bios but cant access it because of no picture and no integrated VGA.
October 17, 2009 3:15:43 PM

My guess is it is a bios settings problem. someday ago i messed with my bios and my graphics card didnt post. i had to pull out the battery and pull it back in and clear bios and cmos to make sure everything is in default settings then my graphics card posted again. using ASUS mobo.. i think u should consult with the ASROCK people.
October 18, 2009 12:59:39 PM

could this be a powersuplly issue? my PSU is not in the certified list. though its 550W which is enough but i read there's something else you need to check about them.
anyone knows?
October 18, 2009 2:39:30 PM

There's a thought. I'm going to test my card on a fiends machine on Monday, Then I'll go buy this -


If it still doesn't work I'll follow it up with a new build :( 
October 18, 2009 8:06:32 PM

i got this working now!
i had to reset the bios (again).
then it just started working. strange...


October 18, 2009 10:43:31 PM

but.. the monitor still seems not to startup :\ it started like 3 times then after booting it remains black.
wonder how often this will happen...
October 18, 2009 11:25:36 PM

I've fixed mine.
I tried it out in the secondary SLi slot (the bottom one) and it took an extra couple of seconds but its posted then windows came up. Strange how it will not work in the primary slot, their both x16 slots.
October 19, 2009 1:01:54 PM

Asrock responded to my query to advise that there were no known issues with my motherboard and the HD 5770 cards. XFX also responded and came up with a very interesting suggestion that I'll check out when I get home. My PSU is 450 Watts but XFX suggested that I look at how many amps the +12V rail can handle.

The second PSU that I tried out at work (also 450W) has two rails, one provides up to 15A, the other 17A. Does anyone know what the requirement for a HD 5770 card is likely to be? Nothing on the manufacturer's website and XFX support haven't gotten back to me on that question yet. I'm probably going to invest in a new PSU anyway. The Coolermaster one linked above certainly looks like an appealling option.

Hopefully this line of attack proves useful to others having similiar problems.
October 19, 2009 1:29:48 PM

I would think you'd find that information looking at the Specifications PSU's must conform to to comply with ATX stardards. Or you could get a multimeter andn test the cables.
October 22, 2009 1:18:27 PM

Resolved.

I did some comprehensive testing with my power supply in another system using this graphics card and it worked fine. I ended up replacing the Asrock AliveXfire-eSata2 motherboard (revision 1.0 BIOS version 3.5) with an Asus board and now have a working system. For some reason the Asrock board just doesn't seem to coexist with a 5770 GPU.
November 27, 2009 1:45:26 PM

I'm having a similar problem even after a motherboard, CPU, & HDD upgrade. Only shared components are the video card & memory. I can't load in the GPU's drivers without BSOD's & Windows 7 going thru a repair. PSU is still the same also but have same type in another system that works great. I'm thinking memory & GPU may not like each other. The old system did the same thing even when I switched out GPU's of similar types (8800's).
March 23, 2011 4:15:24 PM

Hi,

I had the same problem with my PowerColor HD 5770 video card. I didn't find any good solution on the web. These solutions worked for me:

-Bought a DVI-D DUAL LINK cable (my cable was DVI-D SINGLE LINK but my monitor requires to use a DUAL link cable).
OR
-If your monitor supports VGA input, use a VGA cable with a DVI to VGA adapter.

Your actual cable might be in good working condition, but only not the good type of cable. DVI is much more complex than it may appear. Take a look at this for more info:
http://www.datapro.net/techinfo/dvi_info.html
October 18, 2013 9:41:48 AM

chanders : hey i have an xfx hd 6770 1gd ddr5 buy it new band worked about 4 month then suddenly when i turn on my pc its not turning on but when i take oyt the graphic card the computer is booting up but when i put in back the card is not booting up
October 18, 2013 9:41:50 AM

chanders : hey i have an xfx hd 6770 1gd ddr5 buy it new band worked about 4 month then suddenly when i turn on my pc its not turning on but when i take oyt the graphic card the computer is booting up but when i put in back the card is not booting up
!