Sign in with
Sign up | Sign in
Your question

Q9650

Last response: in CPUs
Share
December 20, 2009 8:02:51 PM

hello i am new here as yoy may have already gathered but i already have 1 issue i need help with

i have a xfx 780i motherboard and a q9650 when i try and boot i get either ff or it will post to 20 (these are post codes im referring to) i tried with a celeron 420 and the exact same thing has happened, this may be a stupid question but this mean the motherboard needs replacing or the processor ?

cheers for looking

More about : q9650

a b à CPUs
a c 78 V Motherboard
December 20, 2009 10:45:30 PM

The xfx 780i motherboard specs do not show the Q9650 as compatible. You may want to search the site for a BIOS update.
December 20, 2009 11:50:59 PM

My motherboard doesn't show my RAM as compatible but it still works fine.
Related resources
a c 172 à CPUs
a c 156 V Motherboard
December 21, 2009 12:09:56 AM

treefrog07 said:
The xfx 780i motherboard specs do not show the Q9650 as compatible.

What about the Q9550? If it shows the Q9550 as compatible, the Q9650 should be.
a b à CPUs
a c 78 V Motherboard
December 21, 2009 3:53:30 AM

jsc said:
What about the Q9550? If it shows the Q9550 as compatible, the Q9650 should be.


The green font is the link to XFX 780i's compatible CPUs, it shows the 780i is compatible with the QX6850, QX9650, QX6800, QX6800, and a few others, but not the Q9650 or the Q9550, that's why I suggested redend look for a BIOS update. He said his board would not POST with the Q9650.

Since he has a $300 CPU, he may want to get a BIOS update, if available, or buy a compatible motherboard. Or sell the Q9650..................
December 21, 2009 12:33:08 PM

well to be honest ive had nothing but problems with this board, i was looking at the xfx 750i or teh evga 780i supreme board as they both list it as compatible, however for a short time i did manage to get the q9650 working on the xfx 780i
December 21, 2009 12:34:48 PM

plus i did buy this board second, and due to my pretty bad eyes i can make out slight marking on the slot itself but not for certain
December 21, 2009 6:15:58 PM

bios update would most likely do the trick!
December 21, 2009 9:05:36 PM

i woulde update teh bios but it is not posting with any processor
!