Sign in with
Sign up | Sign in
Your question

Strange bios failure issue - GA-MA785G-UD3H

Last response: in Motherboards
Share
March 23, 2010 9:21:46 PM

I just replaced my older Gigabyte board with this newer one. Because I had heard there were issues with the original BIOS of this board, once I had everything installed I waited to see that it posted and started up Windows OK - then I reset it and flashed the BIOS.

I flashed it to the F4 version of the BIOS. I did it from Q-Flash, using my USB flash drive. It started flashing, and I didn't touch a thing until it finished. Then is said, "BIOS Update Failure!" Uh-oh.

I don't know why it failed. But without rebooting (just letting it sit in the Q-Flash menu) I tried re-downloading the BIOS from a different location. In fact I tried 3 different BIOS versions, but it kept saying "Failure." So I cringed and reset the PC.

To my surprise, it still posted, and I entered the BIOS right away. I went to Q-Flash again, and tried flashing the BIOS again. This time, it was successful.

HOWEVER, now, every time it boots up, it says MAIN BIOS CHECKSUM ERROR! and goes into auto-recovery. It says it is recovering from the "Backup BIOS", it takes a minute or so, then reboots. Then it will always do the same thing, MAIN BIOS CHECKSUM ERROR, recover from backup.

The strange thing is, I can still hit Del and enter the BIOS every time it boots up, as long as I'm quick. But even if I re-flash the BIOS and it says "Successful!", once I reboot, it does the same thing again. I have tried shorting the CMOS pins, and it doesn't seem to change anything.

Gaaaahhh...any help appreciated.
a c 177 V Motherboard
March 23, 2010 9:51:47 PM

I'm showing 'current' as F5b, here:
http://www.gigabyte-usa.com/Support/Motherboard/BIOS_Mo...
If people have problems with 'Main Site' downloaded BIOS, I usually recommend here:
http://www.station-drivers.com/page/gigabyte/gigabyte%2...
but I'll be damned if I even see it there...

Have you tried a "Load Optimized" after the flash?

This is an odd one - I have loaded a 'trashed' BIOS (same file - 2X's [:bilbat:3] ) and had it 'revert', and the BIOS file had passed checksum before the bad load! Thought that was impossible - at least a 1 in 65,536 chance - maybe I should have bought a lottery ticket the same day :pt1cable: 
m
0
l
a c 177 V Motherboard
March 24, 2010 1:59:40 PM

Thought of a possibility overnight (always amazes me how the subconscious mind just 'works away' unbidden :pt1cable:  ) that may require discussion with GB tech:
http://www.gigabyte.com.tw/Support/ServiceCenter.aspx [:bilbat]
Might be that your main BIOS e²rom has a 'stuck bit' (or bits); the flash appears to go OK, but when power is cycled, the bit 'flips', causing your problem, exactly!

When the board starts up, after 'awakening' the processor, the BIOS runs the boot block: one of its first 'duties' is to copy the BIOS from ROM into RAM for faster execution (as every single thing your system can 'do' is 'rooted' in the BIOS, can't afford for it to be slow, and execution from ROM is at least an order of magnitude [if not several orders of magnitude] slower than from RAM...); when it does this it checksums the BIOS to see "do I have a valid BIOS here?" If not, it goes into a sequence of 'failover' modes - and the first of these in dual BIOS setups is to 'revert' to the original as-shipped, stored BIOS. What I believe is happening is that the 'revert' process is having exactly the same troubles; it appears to 'copy over' OK, but once power is cycled, the bad bit (or bits) 'invalidate' the e²rom copy, and the whole thing just happens again at every boot. This would also explain the fact that you are able to enter the BIOS - the bad, or few bad, bits simply aren't getting executed by what you've done so far - someplace in there is an errant goof-up, that will likely cause the BIOS to hang when doing something - but you are unlikely to ever see that, as your odds of 'hitting' the bad spot during the BIOS display/configure block are one in a million (the BIOS is roughly a meg)...

If you do contact GB, do me a favor and let us know what they think - confirmation adds to my (our?) 'tooklit'!
m
0
l
!