Sign in with
Sign up | Sign in
Your question

Unhiding protected system files

Last response: in Windows XP
Share
March 22, 2012 9:54:30 AM

Hello,

After unchecking the "Hide protected operating system files", I get the usual warning. On clicking Yes and Applying the setting, nothing happens (the hidden files are not displayed). And when I open the dialog box again the "Hide protected operating system files" check box is checked again automatically.

Rohit
March 22, 2012 10:51:31 AM

rohitagarwal said:
Hello,

After unchecking the "Hide protected operating system files", I get the usual warning. On clicking Yes and Applying the setting, nothing happens (the hidden files are not displayed). And when I open the dialog box again the "Hide protected operating system files" check box is checked again automatically.

Rohit

Are you unhiding in folders options in control panel ?
March 22, 2012 12:33:53 PM

ksiemb said:
Are you unhiding in folders options in control panel ?

yes.. through Folder Options. Can be accessed through Control Panel and also through Tools>>Folder Options.
And also.. i am using Windows XP SP3
Related resources
March 22, 2012 4:46:53 PM

rohitagarwal said:
yes.. through Folder Options. Can be accessed through Control Panel and also through Tools>>Folder Options.
And also.. i am using Windows XP SP3

It is time to run System File Checker - sfc /scannow from a command prompt
and insert your XP CD when requested, or boot from the CD and repair-install the OS.

March 23, 2012 4:12:15 AM

ksiemb said:
It is time to run System File Checker - sfc /scannow from a command prompt
and insert your XP CD when requested, or boot from the CD and repair-install the OS.


I will try for your above solution.
Meanwhile, I did some research and did the following:

changed the value of

HKCU\software\microsoft\windows\currentversion\exp lorer\advanced
showsupperhidden to 1

I was able to see the hidden system files. I went to the Folder Options again and found that "Hide protected operating system files" checkbox was unchecked.
Just to check if the problem was solved or not, I checked the checkbox and saved. The system went back to the same state and original situation still exists.
March 23, 2012 4:41:01 AM

rohitagarwal said:
Hello,

After unchecking the "Hide protected operating system files", I get the usual warning. On clicking Yes and Applying the setting, nothing happens (the hidden files are not displayed). And when I open the dialog box again the "Hide protected operating system files" check box is checked again automatically.

Rohit



Copy & paste the following black text (Do not include my sig or the dotted line at the bottom) into Notepad, "save-as" with a name you like but quote the name and add the .REG extension to it Example: "FixView.reg". Double-click the new file and then click yes that you want to merge the file into the registry. Problem solved.



Windows Registry Editor Version 5.00

[-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\Hidden]

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\Hidden]
"Text"="@shell32.dll,-30499"
"Type"="group"
"Bitmap"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,\
00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,53,00,\
48,00,45,00,4c,00,4c,00,33,00,32,00,2e,00,64,00,6c,00,6c,00,2c,00,34,00,00,\
00
"HelpID"="shell.hlp#51131"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\Hidden\NOHIDDEN]
"RegPath"="Software\\Microsoft\\Windows\\CurrentVersion\\Explorer\\Advanced"
"Text"="@shell32.dll,-30501"
"Type"="radio"
"CheckedValue"=dword:00000002
"ValueName"="Hidden"
"DefaultValue"=dword:00000002
"HKeyRoot"=dword:80000001
"HelpID"="shell.hlp#51104"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\Hidden\SHOWALL]
"RegPath"="Software\\Microsoft\\Windows\\CurrentVersion\\Explorer\\Advanced"
"Text"="@shell32.dll,-30500"
"Type"="radio"
"CheckedValue"=dword:00000001
"ValueName"="Hidden"
"DefaultValue"=dword:00000002
"HKeyRoot"=dword:80000001
"HelpID"="shell.hlp#51105"









Edit: Do not include this line or anything below it.
March 30, 2012 5:18:37 AM

tigsounds said:
Copy & paste the following black text (Do not include my sig or the dotted line at the bottom) into Notepad, "save-as" with a name you like but quote the name and add the .REG extension to it Example: "FixView.reg". Double-click the new file and then click yes that you want to merge the file into the registry. Problem solved.



Windows Registry Editor Version 5.00

[-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\Hidden]

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\Hidden]
"Text"="@shell32.dll,-30499"
"Type"="group"
"Bitmap"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,\
00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,53,00,\
48,00,45,00,4c,00,4c,00,33,00,32,00,2e,00,64,00,6c,00,6c,00,2c,00,34,00,00,\
00
"HelpID"="shell.hlp#51131"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\Hidden\NOHIDDEN]
"RegPath"="Software\\Microsoft\\Windows\\CurrentVersion\\Explorer\\Advanced"
"Text"="@shell32.dll,-30501"
"Type"="radio"
"CheckedValue"=dword:00000002
"ValueName"="Hidden"
"DefaultValue"=dword:00000002
"HKeyRoot"=dword:80000001
"HelpID"="shell.hlp#51104"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\Hidden\SHOWALL]
"RegPath"="Software\\Microsoft\\Windows\\CurrentVersion\\Explorer\\Advanced"
"Text"="@shell32.dll,-30500"
"Type"="radio"
"CheckedValue"=dword:00000001
"ValueName"="Hidden"
"DefaultValue"=dword:00000002
"HKeyRoot"=dword:80000001
"HelpID"="shell.hlp#51105"









Edit: Do not include this line or anything below it.



I applied the above fix to the registry. But the problem still exists.
March 30, 2012 6:50:47 AM


Stubborn little devil is it... Add this too...



Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
"Hidden" = "2"
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
"ShowSuperHidden" = "0"
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoDriveTypeAutoRun" = "145"
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\Advanced\Folder\Hidden\SHOWALL]
"CheckedValue" = "0"
May 7, 2012 8:55:56 AM

tigsounds said:
Stubborn little devil is it... Add this too...



Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
"Hidden" = "2"
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
"ShowSuperHidden" = "0"
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoDriveTypeAutoRun" = "145"
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\Advanced\Folder\Hidden\SHOWALL]
"CheckedValue" = "0"



This is not working as well...
May 7, 2012 9:04:09 AM



Hello and welcome to Tom's Hardware Forums.

I think it's time to scan for malware because everything Tig has suggested will have worked by now if another utility hasn't messed with your Registry.

Download MalwareBytes from http://www.malwarebytes.org, install and update it then restart into Safe Mode with Networking. Update it again then run the full scan. Restart again back into normal Mode, open MBAM, click on Logs and copy and paste the log back here so we can see what it found.




May 7, 2012 9:06:18 AM



Secod thought - have you tried opening a Command form and typing attrib /? and pressing Enter? Do that and explore the options and see what's going to work for you - attrib -a -s -h is my best guess but navigate to that folder first.


May 7, 2012 9:11:40 AM

Saga Lout said:


Secod thought - have you tried opening a Command form and typing attrib /? and pressing Enter? Do that and explore the options and see what's going to work for you - attrib -a -s -h is my best guess but navigate to that folder first.




Hi,

Thanks for the response.
My problem pertains to the overall system setting and not to any particular folder. Hence, attrib will not serve the purpose here.
May 7, 2012 9:44:04 AM

Saga Lout said:


Hello and welcome to Tom's Hardware Forums.

I think it's time to scan for malware because everything Tig has suggested will have worked by now if another utility hasn't messed with your Registry.

Download MalwareBytes from http://www.malwarebytes.org, install and update it then restart into Safe Mode with Networking. Update it again then run the full scan. Restart again back into normal Mode, open MBAM, click on Logs and copy and paste the log back here so we can see what it found.





Hi, I can try what u have posted above, however a question comes to my mind.
If there's a malware that is causing the issue then how come the files get displayed when I change the value of

HKCU\software\microsoft\windows\currentversion\exp lorer\advanced
showsupperhidden to 1

I have mentioned this earlier in my thread.

May 7, 2012 2:46:29 PM



I took that to mean you overarched your Registry amendment by reticking the box in Settings. My money is still on malware causing the original problem and that remains while the malware does.

As for attrib, the folder concerned is C: so at the Command Prompt, type chdir c: and hit Enter. Then run an attrib command to apply the setting to the entire C: folder


I've been trying to post this since ten o'clock GMT+1 this morning but the "Forum no available" bug keeps hitting me.
!