Sign in with
Sign up | Sign in
Your question

Can I format an external HD that I can't access?

Tags:
  • Hard Drives
  • HD
  • Storage
Last response: in Storage
Share
August 17, 2011 6:16:44 AM

Hi TH community. I've been scouring forums and google for a situation like mine to no avail so I signed up here just to ask you guys. Hopefully someone will have a resolution or point me in the right direction. My computer is just a stock HP PC with Windows 7 Home Premium (64 bit) from Walmart, about a year old.

PRODUCT:
I have an 2TB WD external hard drive. The product number is WDBAAU0020HBK-01 and this is what it looks like:

http://www.wdc.com/en/products/products.aspx?id=260


ISSUES:
1. When plugged in, the HD is not shown in My Computers until after 5 minutes. Even after the HD appears, it is inaccessible. As soon as you click/right-click on the Drive letter or double-click the HD icon, the Windows Explorer goes into its "Not Responding" thing. So my files never even display for me to see.

2. The drive shows up in "Device Manager" and upon checking it says the drivers are up to date and the drive is running fine.

3. The drive does NOT show up in "Disk Management" though, and frankly the other drives won't even display until I disconnect that bad external HD.

4. Sometimes other applications freeze until I disconnect the external HD.

5. I can NOT restart or shut down my computer if that external HD is still hooked up. As soon as I unplug it then the shutdown/restart resumes.

Other notes:

- The drive has no on-off switch, but it has a light that blinks when it's busy. Since the drive failed, whenever I plug it in, the light blinks for what seems like forever. Even after it stops blinking, trying to access the drive will make it start blinking again.

- The HD does spin and I can hear it when I place it up to my ear. However it sometimes does slow down or stop when I hold the drive diagonally.

- When windows explorer is "Not Responding" I'll unplug the HD and then the computer will ask if I want to format the drive. "Cancel" cancels it and "Format" tries to format but immediately gives me a pop up saying to make sure the drive is plugged in. (Note that the option to format only shows up AFTER I've disconnected the drive). But even after reconnecting the HD and clicking "format" it fails to format.


WHAT I WANT TO DO:

So basically, all I want to do now is to be able to FORMAT the external HD, but I don't know how to format when:

1. I can't even touch it in the COMPUTER window

2. It doesn't show up in DISK MANAGEMENT (and it prevents the other drives from displaying until I disconnect it)

I can only "explore" the drive in DEVICE MANAGER in which it says everything is fine.


WHAT HAPPENED BEFORE THE DRIVE BEGAN ACTING UP:

I had some movies on the external drive and I wanted to copy a movie over to a thumb flash drive (to play on my flatscreen). When I clicked on the external HD, it was taking WAY longer than usual for the movie files to show up. It usually takes maybe 10 seconds to display. But after 5-7 minutes, it looked like the drive wasn't going to load so I clicked on "X" to close it but then it REALLY froze (as in I couldn't even move the window around). So I just disconnected the USB cable.

Usually if I do that, I might get a pop up saying it wasn't removed properly but the window will disappear. This time after I disconnected the USB, the folder was still there on the screen all frozen, with the files still displaying.

So I just End Task with Task Manager. I connected the external drive again and it's been like is now ever since.


WHAT I'VE TRIED:

Spinrite 6.0, but it didn't work. Or at least the screen it was at didn't give me any options to progress.

Tried the Hirens HDD Regerator and it looked like it was slowly checking the sectors, but would have taken a week to complete so I haven't fully tried it.


CONCLUSION:

Sorry for making this so long. If anyone has any knowledge or can point me to an existing thread that might help, that would be great. I've seen a few threads that are similar, but for mine I can't do anything in "DISK MANAGEMENT". Again, I just want to format so I can start using it again, even though I realize it may fail again in the future. Thanks in advance everyone, this forum has saved me from grief many times before, I hope it can come through again!!!

More about : format external access

a b G Storage
August 17, 2011 7:28:51 AM

You've exhausted a lot of the usual options, so it's time to try the unusual options. If you know someone with a Mac then plug the drive into their computer and try to use diskutil to format the drive. If you know someone who uses Linux then plug the drive into their computer and try to use GParted to format the drive. If everyone you know uses Windows then you can download a copy of Ubuntu from their website and use the Ubuntu Live CD to run GParted and hopefully partition the drive.

http://www.ubuntu.com/download/ubuntu/download
m
0
l
a c 102 G Storage
August 17, 2011 1:32:33 PM

Have you tried connecting your ext HDD to any other computer? If so, did it work there?

If it fails on a second computer, try switching your USB cable. If that fails, the HDD is likely defective and will need to be replaced.

Good luck!
m
0
l
a c 392 G Storage
August 17, 2011 2:03:03 PM

If the drive is out of warranty, you might try removing the drive from the enclosure and hooking it directly to the motherboard and see if it's accessable that way. If this works, then the enclosure has failed, but the drive should still be good. If this doesn't work, the drive is most likely dead and needs replaced.
m
0
l
August 17, 2011 2:58:17 PM

Thanks all, I'll try all the suggestions and report my results later tonight. I appreciate it!
m
0
l
September 28, 2011 2:24:05 AM

Finally got back to responding here. Unfortunately none of the tricks were able to help me out. I even opened up the case and removed the adapter. Hooked it up like a regular internal HDD and still nothing.

I hooked it up to a different computer and nothing as well.

That was $100+ loss that I just have to accept!! Might try SSDs now.
m
0
l
a c 336 G Storage
September 28, 2011 4:40:17 AM

When you say "nothing", do you mean that the drive didn't appear in BIOS?

Be aware that Elements drives are hardware encrypted, whether or not you have set a password. This means that the drive will show up in Disk Management as uninitialised. The bridge chip (eg Initio INIC-1607E) on the USB-SATA bridge board handles the encryption.
m
0
l
!