Sign in with
Sign up | Sign in
Your question

Faulty on-board SATA controller?

Last response: in Motherboards
Share
Anonymous
a b V Motherboard
March 28, 2010 11:19:23 PM

Hi all

I have an intersting problem with my Gigabyte GA-P35-DS4 Rev 2.1 mobo and am trying to track down where the problem lies. As a bit of history. I have had 2 hard drives fail in 5 months and a third one appeared to have died tonight. I use native SATA mode with AHCI and all seemed fine up until tonight after several weeks of all seeming fine. I rebooted the machine and the machine locked up at the POST screen as soon as the internal single HD is detected. This would seem to indicate a faulty drive on the face of it. However, having 3 fail in just under 5 months I got suspicious. So I unlugged the suspect drive and went in to the BIOS and disabled all the native SATA\AHCI settings. I then plugged up the drive again and at this point to my surprise the machine booted up normally and windows 7 installed the ATA drivers and upon rebooting all is now fine. My question is have I got a faulty on-board SATA controller that is causing the drive(s) to stop working with the onboard SATA controller after some perod of time for some reason please? Any other ideas gratefully received please? Just as a final piece of information even now I still cannot go back to native SATA mode as it still causes the mobo to hang as soon as the hard drive is detected. I think the number at the top right of the screen is 23 when this happens.

Many thanks in advance.

Regards,

Paul Lemonidis

More about : faulty board sata controller

a c 177 V Motherboard
March 29, 2010 12:14:42 AM

Which ports do you (did you?) have your drives plugged into? Have you thought about the possibility of a PSU problem with the SATA connectors? Just out of curiosity, do you: A - have the thing plugged in through a surge protector, and B - possibly have a motor load of some sort on the same household circuit? Older refrigerator (newer ones are 'power factor corrected' which usually obviates the problem...), fan, god forbid, use a drill in a 'connected' outlet on the same circuit? Reason I ask is motors have a bad habit of 'unloading' a spike every time they're disconnected, either by a switch, or by having the plug pulled. One time, I even had a service call from some people who had a CNC controlled machine that was 'dancing' all over the place, and ruining parts - turned out some dolt had hooked up a welder to the machine, and was welding some &^%$ attachment to it!! In industrials, we put an RC 'snubber' across every single motor load that can possibly be 'switched' off mechanically - (TRIAC switched stuff 'doesn't count', as it can only switch as the AC line 'crosses zero', which doesn't have the problem) but a 120 VAC motor can 'throw' a three or four thousand volt 'spike' [:lorbat:3] if switched 'mechanically' at line 'peak'!

I have heard of some oddball problems caused by swapping back & forth between AHCI and SATA, but never of it sending a drive (or three!) 'to heaven'[:lorbat:5]!
Anonymous
a b V Motherboard
March 29, 2010 12:32:54 AM

Thanks for your quick reply. I don't use a surge protector but may do now! Although I don't think that is the issue to be honest as I have been using the same sockets for several years. Dodgy power to the SATA ports is possible which would mean a faulty mobo but would the circumstance be so exact and repeatable now. I cano now not sitch to AHCI mode and get the hard drive to be properly handled by the mobo. It just hnags as soon as it detcts the hard drive and never dispalys any info about it. However, I am inclined to think it is not a power problem, as the the first time this happened today I simply warm rebooted the machine after it had been on for several hours without error. Also this has been running fine for several weeks and was fully AHCI etc from the outset of installing Windows 7 x64. I only switched to IDE mode after the machine suddenly decided it would not post when in AHCI mode out of the blue. What makes me suspicious that the inital symptom of hanging at post has now happened three times with the 3 different hard drives t I just took the apparent failures as hardware failures and now suspect that when same symptom occurred before that if I had switched to IDE mode the drives may have worked. Could this be anything other than a faulty motherboard? I don't see how now unless you know different please? At present I cannot get the machine to POST when in AHCI\native SATA mode. Any more ideas or thoughts most welome please? Many thanks in advance.
Related resources
a c 177 V Motherboard
March 29, 2010 1:22:10 AM

Quote:
Dodgy power to the SATA ports is possible which would mean a faulty mobo

Welll - not really, the power to the drive is supplied by the PSU, one way or another - nothing but signals passing through the MOBO SATA connectors...

I've wondered about the problems I have heard of regarding 'switching' from AHCI to SATA and back, as the drive 'doesn't know any better'! It's not like the drive is formatted any differently, or the MBR (master boot record) is 'built' differently; when you switch to AHCI, all you're really doing is 'handing off' the drive 'discovery' and intitialization (and, of course, control - once the drivers are loaded, after OS initialization...) to a different 'chunk' of the BIOS - the 'option ROM' (RAIDBIOS, or AHCIBIOS), instead of the standard POST 'discovery' stuff...

One thing I'd consider is to flash the latest BIOS; about six or eight months ago, most all the GB BIOS with AHCI controllers were updated with new 'option ROM' code (which 'takes over' the drive when in AHCI or RAID), accompanied by a new Intel driver release.
Quote:
when in AHCI\native SATA mode

I'm a bit confused here - don't quite know what you mean by 'native SATA'? In your BIOS - like pretty much all GBs with an ICH and a jMicron (GB calls 'em GSATA) controller, you have a couple settings toward the top of your "Integrated Peripherals" page:

"SATA RAID/AHCI Mode" is labelled, well, 'peculiarly'; it says "Disables RAID for the SATA controllers and configures the SATA controllers to PATA mode", but it's not really accurately worded - there is no 'PATA' mode - if it's not AHCI, and it's not RAID, well, then it's just plain SATA (it's ATA/IDE compatible that way, but it's still a SATA controller!

"SATA Port0-3 Native Mode" simply turns on (enabled) or off interrupt sharing - unless you are one of the lucky six people who ever bought windoze ME, you needn't worry about this one - interrupt sharing has been supported forever... [:bilbat:6]

The 'lower down' settings only apply to the secondary jMicron controller, which is also responsible for the actual IDE port...

People are often confused by the fact that, even though there is no 'master/slave' mode in SATA, the 'found' drives will be shown on the standard POST screen as "channel#/Master" and "channel#/Slave"; ignore the master/slave designations, they mean nothing on actual SATA controllers, and are some kind of 'compatibilty vestige'! If the controller is configured in either AHCI or RAID, this 'discovery' process is not done in the standard (IDE) POST - because you can't have it both ways - if the drives were discovered in both POST (IDE) mode, and AHCI or RAID mode - the board would 'think' it has two 'hook-ups' to each drive! So, after the standard POST runs, the 'discovery' done by the 'Option ROM' is run...

Have you run a DOS-based, or bootable utility from your drive manufacturer to confirm that the drives are actually damaged? It may be that something (what is a longer treatise - virus? bad driver? ??) is ditzing up the MBRs on your drives, and a drive with a 'ruined' MBR certainly looks dead! A DOS' fdisk /mbr should repair a broken one...

Are these, by any chance, all fairly good sized Seagates - 'nother problem - the dreaded "Seagate Stutter" - firmware 'oops' on their part!
Anonymous
a b V Motherboard
March 29, 2010 9:05:09 PM

Many thanks for your reply. If it were a PSU problem why would the machine work fine in IDE compatibilty mode and only fail to POST in AHCI mode?

By native SATA mode I mean not comptaible with PATA. Some BIOS's refer to this as AHCI as oppsoed to legacy under SATA compatibilty mode. In this mode to install XP you would need to have the drivers at install time (pressing F6 etc.) or the machine will BSOD at boot up everytime.

I will be getting the machine checked over anyway now as it is still under a 3 year warranty although getting a replacement MOBO may mean a fair time with no machine and this motherboard is now discontinued and I am struggling to even find one at any resonable price on the Net.

Many thanks for your continued help.

Regards,

Paul Lemonidis.
a c 177 V Motherboard
March 30, 2010 1:20:10 AM

Quote:
If it were a PSU problem why would the machine work fine in IDE compatibilty mode and only fail to POST in AHCI mode?

I guess I wasn't 'getting that'; I took it that you had two drives fail (as in - 'dead') previously, and now a third... That's one reason I asked if you had tried a 'bootable' or DOS drive utility to verify actual failure?
Quote:
By native SATA mode I mean not comptaible with PATA

But there's nothing like that, or, at least, not referred to like that - the current overall drive control set-up is the SAS stack, which encompasses SATAs, and gives 'backward' compatibility to PATA/ATA/IDE (actually, all names for the same thing...); but 'native' is generally in reference to an OS (the 'Native Mode' thing in GB manuals is, I believe, just an incredibly bad translation...); the SAS stack has been implemented in windoze for a long time; AHCI drivers just became 'native' (meaning you don't have to load another manufaturer's driver) in seven - and I'm still trying, in off moments, to determine whether just the southbridge AHCIs are 'in', or if it can install jMicron or Marvells as well...

I still think it's worth finding out if you're somehow suffering from MBR corruption - might look at this, especially the last post and its pointers:
http://social.answers.microsoft.com/Forums/en-IE/w7repa...
!