Sign in with
Sign up | Sign in
Your question

Need assistance GA-X58A-UD5 mobo connections and bios

Last response: in Motherboards
Share
March 29, 2010 3:43:22 AM

I just purchased gigabyte ga-x58a-ud5 and corei7-930. I also purchased a WD Velociraptor 300gb 10K HD as my main drive and a WD Caviar Black 1TB sata 6.0Gb/s to use as my data drive. No RAID. Win7 pro 64bit. This is my first build and im trying to figure out a few things.

The board has 6 intel ICH10R ports , 2 Marvell 9128 (sata6Gb/s) ports and 2 gigabyte sata2 ports.
1. Does it matter what sata ports i use on the board? I have the Velociraptor plugged into one of the gigabyte sata 2 ports and the Caviar Black plugged into one of the Marvell ports and my optical drive and my front panel ports plugged into 2 of the ICH10R ports.

2. Is it ok that they are all setup as masters not slaves.
3. Is it ok that my optical is in sata0.
4. Also, should i have native mode in the Intel ICH10R South Bridge set as enabled or disabled(default) .

I gave the velociraptor Hard Disk Boot priority in the bios and i have everything configured IDE.
5. I wasnt sure if i should configure as AHCI instead.
6. Should i have HPET Mode set to 64-bit(i read somewhere that this has caused systems to slow down in the past)
7. Mobo display shows code FF. Is this OK? I believe it is but im not sure.
a c 177 V Motherboard
March 29, 2010 1:21:15 PM

Mostly explained here:
http://www.tomshardware.com/forum/272007-30-ignore-post...
under "Sorting out SATA"

Here's what I would do:
Put the VR on the ICH, at port 0.
Put the Black on the ICH at port 4.
Put the DVD on the GSATA (jMicron) controller.
'Native Mode" should be "Enabled".
The 'Master/Slave' indicated means nothing for SATAs - just ignore it.
For sevenX64, HPET on and at 64bit.

'FF' simply indicates it has completed POST (power on self test):
http://forums.tweaktown.com/f69/my-post-deleted-questio...
m
0
l
March 29, 2010 6:27:34 PM

bilbat said:
Mostly explained here:
http://www.tomshardware.com/forum/272007-30-ignore-post...
under "Sorting out SATA"

Here's what I would do:
Put the VR on the ICH, at port 0.
Put the Black on the ICH at port 4.
Put the DVD on the GSATA (jMicron) controller.
'Native Mode" should be "Enabled".
The 'Master/Slave' indicated means nothing for SATAs - just ignore it.
For sevenX64, HPET on and at 64bit.

'FF' simply indicates it has completed POST (power on self test):
http://forums.tweaktown.com/f69/my-post-deleted-questio...


Thank you . I will chk out those links latr. One thing though. Wouldnt i better off putting the caviar black on the marvell 9128 ports since they both have sata6.0gb/s capability? Or does it not work the way i thought it did.
m
0
l
Related resources
a c 177 V Motherboard
March 29, 2010 7:15:00 PM

Nothing physically comes even close to requiring the bandwidth that SATA3 offers - not even solid state drives! And, the Intel drivers for the ICHs have been optimized and re-optimized, forever, by people who really 'know their business'! My guess - it will be a solid year of revisions before Marvell can close the gap [:bilbat:1]
m
0
l
March 30, 2010 1:13:23 AM

Should ports on mobo..... sata0 ,sata1 , sata2, etc. be ide channel0, ide channel1, ide channel2,etc. in my bios settings or do they not match up that way? I have channel 0-7 then channel9(no channel8) in my bios and only a few match up.
m
0
l
a c 177 V Motherboard
March 30, 2010 1:22:12 AM

The 'IDE channel#/Master/Slave' thing has no meaning whatsoever for SATAs... I repeat: "Just ignore it!"
m
0
l
March 30, 2010 1:43:31 AM

Understood. Thank you for taking the time. Ive been reading that post you recommended. Just what i needed. Thanx
m
0
l
a c 177 V Motherboard
March 30, 2010 1:56:19 AM

Always welcome! :hello: 
m
0
l
!