Sign in with
Sign up | Sign in
Your question

SSD Running slow on one SATA port

Last response: in Storage
Share
August 19, 2011 5:48:05 PM

Mobo - ASUS P8Z68-V LE
SSD - Crucial M4 64GB connected to 6Gbps SATA Port 1 (1st port)
SATA Controller - IDE Mode
OS - Win XP 32

I just finished building this system last weekend. I would get BSOD trying to install Windows XP so I switched the SATA controller to IDE mode. OS would boot very fast in about 30 seconds. Last night I added an existing 1TB drive to the system and started it, I immediately got a error past the BIOS screen saying something "Drive error - press Ctrl+Aly+Del to restart". After that the OS boot was very very slow it took about 2 to 3 minutes to come up. I disconnected all other drives except the SDD and rebooted and still it was very slow. I finally connected the drive to the second 6 Gb SATA port and it was back to the original speed, very fast. I then connected the rest of the 3 HDDs, this time one of the HDD, a 500GB Caviar Black, was connected to the 1st SATA 6Gb port and restarted, everything was working fine no errors and everything back to the original speed. I later copied about 600 GB of data between two 1TB HDDs, both connected to 3Gb ports and the transfer rate was pretty amazing.

I did not get a chance to swap the ports/drives back to the original config nor did I try to check the speed of the HDD connect to the 1st 6Gb SATA port yet, will do that when I get back home. But the 500GB drive connected to the 1st 6Gb SATA port was reachable and all files viewable no noticeable delays either.

My question is, what in the world happened? what might have caused the drive to run so slow on that particular port? Is the port partially fried somehow? Did anyone have any such experience before? When I reach home, what do you recommend I do first?
a c 284 G Storage
August 19, 2011 6:02:14 PM

According to the Intel motherboard database your motherboard has two SATA Controllers. One is the Intel controller integerated into the Z68 chipset. The second one is a Marvel controller. Normally the Intel controller is preferred. You probably got the configuration mixed up. Consult your motherboard manual to figure which SATA port is connected to which controller.
m
0
l
August 19, 2011 6:49:00 PM

The two 6Gbps port are on Marvel controller and the four 3Gbps ports are integrated Z68. Originally I had the SSD connected to 6Gbps port #1 and HDD to Port #2, after facing the issue I just switched them and it worked fine...
m
0
l
Related resources
a c 284 G Storage
August 19, 2011 7:07:08 PM

I made a mistake. I got the models mixed up. There is no Marvel controller. Here are the specifications for the P8Z68-V LE according to Asus:

Intel® Z68 chipset :
2 x SATA 6Gb/s port(s), gray
4 x SATA 3Gb/s port(s), blue
Support Raid 0, 1, 5, 10
Support Intel® Smart Response Technology on 2nd generation Intel® Core™ processor family

http://www.asus.com/Motherboards/Intel_Socket_1155/P8Z6...
m
0
l
August 19, 2011 7:33:08 PM

In bios, there is only one controller shown. there are two set of ports as you pointed out. A set of two gray and another set of 4 blue. I have only been using the two gray ones. I swapped the SSD and HDD between the two gray ones and it worked. The question is why is the SSD slow on one of them and working just fine on the other... seems strange to me... will do some more monkeying around when I get home and post the results.
m
0
l
!