Sign in with
Sign up | Sign in
Your question

Reboot and Select Proper Boot Device

Last response: in Motherboards
Share
March 31, 2010 2:28:25 AM

So I'm completely stumped on this issue. I have an ASUS P5Q mobo with three HDD connected to it via SATA. The computer worked fine until tonight when I shut it down for an hour or so. When I turn it back on, the computer came up with this message. So I hopped into BIOS and the BIOS no longer recognizes the HDD with my Windows partition, but still can locate the other two. Opened it up, checked the connections and restarted with the same issue.

I put an Ubutnu live CD in and I can mount the HDD just fine as well as browse everything on it. Logged out and restarted and again got the same message. Tried putting my Win7 dvd in to see if it could find the HDD and again, no luck. I'm not even sure if this is the right forum for this issue, but needless to say I'm a bit irritated and confused and would love some insight and suggestions as to what might be going on.
March 31, 2010 3:14:30 AM

After poking around the Live CD and looking back at the bios, apparently the BIOS does recognize the HDD that my Win7 partition is on. It recognizes all but one, which is used for misc storage that the Live CD can still access.

Despite this, still can't boot the computer up with receiving the message to reboot or select a proper boot device, etc.

EDIT: For some reason I can't select the HDD with the Win7 install in the boot device priority list. It only lets me select a removable drive, another HDD, an ATAPI CD-ROM, and my DVD drive.

EDIT2: Again for some reason the order of the HDD listing in the BIOS had been rearranged, with the two storage drives as Sata 1 and 2 and the Win drive last. Switching them around let me select it in the boot order.

The question for me now is, does anyone have any idea WHY the bios would switch the drive order around and cause such an issue for me through simply shutting down.
m
0
l
a b V Motherboard
March 31, 2010 3:49:38 AM

Maybe corrupted? Could try flashing to most recent, loading defaults, then setting everything manually again.
m
0
l
Related resources
!