Sign in with
Sign up | Sign in
Your question

Windows 7 and ATI 4850 no display on TV

Last response: in Graphics & Displays
Share
October 25, 2009 8:23:29 PM

I'm having issues getting anything to display from my computer to my TV.
System specs are:

i7 920 (currently running at stock speed)
Radeon HD 4850
G.Skill 6 GB RAM DDR3
Asus P6T Deluxe
WD 640 Cavier Black x2 in RAID0
Windows 7 64-bit

This is a fresh install of Windows 7, latest chipset and MOBO drivers. Latest BIOS revision as well.

I'm trying to get my computer to display on my 61" Samsung (HL61A750) TV, but I'm getting "mode not supported". With a fresh install of Windows 7, I'm able to get everything installed correctly, but as soon as I load the ATI drivers, after rebooted, the "mode not supported" message pops up on my TV screen. I'm able to get a display on my TV before this point. I've tried all the Catalyst drivers from 9.1 - 9.10. I've also tried every resolution to no avail and forced different refresh rates. I've tried different connections to my TV, HDMI to HDMI, DVI to HDMI, Component to Component, and DVI to VGA, but still the same error.

This only happens though on Windows 7 64-bit. When I try the same computer setup with Windows XP or Windows Vista 64-bit, both work perfectly fine. I only lose display with Windows 7, and only after I load the ATI drivers. System will boot and display in safe mode as well.
If I hook up a computer monitor and set up a dual display with my TV as a second display, it will work at resolutions of 720p or below. If I try to set the TV to 1080p (1920x1080) I won't get a display on both. If I try to do dual display with the TV as the primary display, I get "mode not supported" for any resolution. I also double checked refresh rates and tried forcing 59hz and 60hz, but still the same error.

One other thing I did was, I took my NVIDIA 9800GT from my other computer, installed it in the system with Windows 7, and I was able to run it just fine on my TV at any resolution.

Does anyone have any suggestions or know of any solutions? It seems to me that it's a driver issue with ATI cards and Windows 7.
a b $ Windows 7
October 26, 2009 2:20:52 PM

Open CCC, Digital Panel and HDTV Support, select your TV's settings.

Then Display Options. Select Manual Detection. Force TV Detect.
m
0
l
January 28, 2010 7:03:38 AM

The issue seems to have been fixed with ATI's newest drivers, version 10 (posted on 1/27/2010)
m
0
l
!