Sign in with
Sign up | Sign in
Your question
Solved

New i7 920 build won't POST - evga mobo to blame?

Last response: in Systems
Share
October 15, 2009 1:41:40 AM

Hello all,
I recently put together an i7 system and finally installed the CPU today. They system won't POST--and by that, I mean that I get nothing. All of the fans and SATA devices spin up, but the motherboard doesn't make any noise and it doesn't give an error code.

Here are the specs:

Core i7 920 w/ stock HSF (cleaned off standard thermal paste and applied AS Ceramique)
EVGA X58 SLI Micro motherboard
3x 2GB OCZ Platinum DDR3
Cooler Master UCP 700w PSU
ASUS HD4890
Cooler Master Storm Scout case
WD Caviar Black 640GB
generic SATA DVD burner

I had most of this build together and in the case by the time the CPU and GPU arrived in the mail. I carefully installed the CPU and GPU and tried to boot. The fans and SATA devices all seem to be working, but the GPU had three bright red LEDs. Thinking it was the graphics card, I pulled it and tried to boot again to see what the motherboard would tell me. Again, everything spins up but otherwise nothing--no beeps, no POST code. Two things to note--the motherboard does have a blue standby LED that comes on when it is plugged in and off, and a yellow LED near it that, according to the manual, indicated functional memory slots. This is lit when I try to boot the machine. There's also supposed to be a green LED that is lit when the system is powered on, but I haven't seen it yet. Also, all of the fans in my case are powered directly from the PSU and not the motherboard.

When pulling the GPU gave me nothing, I tried removing the motherboard entirely to rule out a short in the case. I've also tried resetting the CMOS both with the button on the motherboard and by pulling the battery. I think I've ruled out faulty memory; each stick and three different slots (and no memory) give me the same result.

I was also having an issue with the system speaker--the plug seemed a bit flaky, but it should be properly connected. Not hearing anything from it leads me to suspect the motherboard.

And I've gone over the checklist--everything is connected properly, everything is seated properly, and all of these parts are brand new.

What else can I do to isolate the problem? Do you think it's the motherboard?

Thanks!
a c 136 B Homebuilt system
a c 97 V Motherboard
October 15, 2009 1:46:05 AM

got BOTH mb power connectors installed?
m
0
l
October 15, 2009 1:48:57 AM

The 24-pin main power connector and the 8-pin CPU connector are both plugged in, yes.
m
0
l
Related resources

Best solution

a c 136 B Homebuilt system
a c 97 V Motherboard
October 15, 2009 1:56:37 AM

try rebuilding from from scratch with the mb outside the case .

Rest it on a dry wooden board , or heavy cardboard . NOT plastic which could melt .

Install cpu and heat sink first , then RAM in the correct slots ,mb speaker , then connect the psu and try to boot by shorting the on/off switch contacts with a screwdriver

Beep codes?
Share
October 15, 2009 2:07:16 AM

I'll try that now.
I did attempt booting again and looked closely, and the green light does come on--it's just overpowered by the blue one.
As for beep codes, that's what makes me think the mobo might be bad. I don't get any. The built-in diagnostic readout doesn't light up either.
m
0
l
October 15, 2009 2:33:29 AM

Done. I reseated the CPU and cleaned/reapplied thermal paste. I used a little bit more this time , closer to theArctic Silver instructions, but the spread of paste looked pretty good when I removed the heatsink.
No change in behavior (though I did not try installing the GPU) and no beep whatsoever.
Should I try the GPU again, just for the hell of it?
m
0
l
a c 136 B Homebuilt system
a c 97 V Motherboard
October 15, 2009 2:37:31 AM

your problem doesnt involve the gpu since you cant get beeps from the mb

try reseting cmos/bios by pulling the battery for a few minutes [ or shorting the appropriate jumper ] and check that the mb speaker is correctly connected .
then try again
m
0
l
October 15, 2009 3:30:27 AM

No luck :( 
If the motherboard was working I would expect to see something, anything on the diagnostic display.
I'm going to contact EVGA support, but right now it's looking like I'll have to RMA.
m
0
l
!