Sign in with
Sign up | Sign in
Your question

Hard drive has become inaccesible..

Last response: in Storage
Share
August 26, 2011 12:32:27 PM

My external hard disk has become inaccessible on my laptop. I can use it on any other laptop normally but not on mine. I am using windows 7. Please help...

More about : hard drive inaccesible

August 26, 2011 12:56:06 PM

How is it inaccessible? Like you can see it in My Computer but can't open it or it just never shows up when you plug it in?

Any error messages when you plug it in or try to open the drive?

Interface? (firewire, usb1,2 or 3, eSATA)

Recently had any other issues with the drive or laptop itself before the drive became inaccessible on your laptop?

Are you using the same interface cable with your laptop that you're using with other laptops?

Can you use other devices on the same port(s) on your laptop that won't work with your external drive?


Answers should help us narrow this down.



m
0
l
August 26, 2011 4:05:40 PM

arson94 said:
How is it inaccessible? Like you can see it in My Computer but can't open it or it just never shows up when you plug it in?

Any error messages when you plug it in or try to open the drive?

Interface? (firewire, usb1,2 or 3, eSATA)

Recently had any other issues with the drive or laptop itself before the drive became inaccessible on your laptop?

Are you using the same interface cable with your laptop that you're using with other laptops?

Can you use other devices on the same port(s) on your laptop that won't work with your external drive?


Answers should help us narrow this down.


Actually i was copying some data on my laptop and lights went off. Laptop was on ac power supply. So wen i restarted it i cudnt see the hard disk.

It gives no error message. But i can see it in Disk Management option and not in My Computer.

I tried on other laptop with same interface cable and port is also working for pendrive and netsetter.

I even tried assigning it a drive letter but there it gives error message that Operation Failed..
m
0
l
Related resources
August 26, 2011 4:19:28 PM

What kind of partition does Disk Management list for your external drive? If the drive is listed as a RAW or UNALLOCATED partition, then it means it's not formatted. If it is listed as Primary, Active, Healthy, System etc... then that should mean everything is still intact as it was before and we need to figure out why Windows doesn't want to mount the drive.

In Disk Management, is it assigned a drive letter the same as another drive by any chance? I've had this happen before. If this is the case and you can't change the drive letter of the external, then just change the drive letter of the other drive that's assigned the same letter. You may need to reboot again though for it to show up in My Computer.

Or, is it not assigned a drive letter at all?
m
0
l
August 26, 2011 4:36:06 PM

It shows it as a primary partition. but no drive letter assigned to it.

On its left it shows : Disk 2
Basic
298.09 GB
Online
m
0
l
August 26, 2011 7:18:54 PM

Ok, so Windows isn't mounting the drive for some reason. Right click on the drive in My Computer or Disk Management, doesn't matter which, and click properties. Tell me what it says the file system and type are. It should say NTFS and Local Disk.

Once you check that, go into Device Manager and click on your computer name at the top of the list and click the scan button right above that on the toolbar. See if that detects anything. If not, shutdown the computer, unplug the drive and rescan the computer for hardware again once you boot back into Windows so that it'll detect all hardware without the drive. Then just shutdown again, plug the drive back in and rescan again with the drive connected and see if we can trick Windows into seeing the and autoassigning a drive letter to the drive again. Sometimes you can get Windows to detect it again on it's own.

Maybe I'll think of more to try by the time you respond if none of this works.
m
0
l
August 27, 2011 7:39:38 AM

hey.. it worked.. thnks.. :) 
m
0
l
August 27, 2011 6:01:16 PM

Sweet, glad I could help.
m
0
l
!