Sign in with
Sign up | Sign in
Your question

Just got a 5770 and an Antec 650 Power supply and NIC card doesnt work

Last response: in Graphics & Displays
Share
October 27, 2009 2:41:25 AM

Core 2 Quad Q6600 (K) 2.4 GHz (95W)

*
800 MHz front side bus
*
Socket 1066
Motherboard Name: IPIBL-LB

Sapphire 5770 Card
Antec Earthwatts 650 Watt Power Supply
4 gig ddr2 Ram

The specs on the motherboard say 1 pci-e x16 slot could that be the problem since it doesnt say pci-e 2.0?
October 27, 2009 2:43:00 AM

Ok what happens is when i turn on any game the NIC card stops working. It works fine until I turn on any game. I have already downloaded and installed the recent drivers for the video card.
a b U Graphics card
October 27, 2009 3:09:12 AM

Hm. How do you everything plugged in powerwise outside the case? I had an issue with my monitor going black during gaming at times and turned out I was running too much from one cord(pc is on opposite side of room from outlets, so had to run heavy duty extension cords), but once I split it up between a couple of outlets the problem vanished. Might start there.
Related resources
October 27, 2009 3:27:16 AM

i would think if that was the problem though, that something bigger like the monitor would stop working besides the NIC card cutting out
October 27, 2009 4:45:04 AM

HELP PLZ
a b U Graphics card
October 27, 2009 11:24:56 PM

That would be the first place I'd start man. In my situation, the monitor just went black, but stayed on, the game stayed on as well, and the tower as well. The other things you could try I guess would be check for updated NIC drivers. If none of this works, you could always grab a cheap add in NIC card that fits in a PCI slot.
!