Radeon X1950 Pro IceQ and warcraft 3

My old motherboard fried, so I replaced it with an old ASUS k8n SE deluxe, and a new hard drive and now windows 7, those were my only changes, yet now, with the drivers fully updated for windows 7 on my http://www.newegg.com/Product/Product.aspx?Item=N82E16814161082, the game studders when I play online against other people, like I am lagging but I know it's not my connection. I have no clue how to fix this, I tried using older drivers but then warcraft says it needs direct 8.1x or higher to be able to play.

Can someone shed some light on this matter?
13 answers Last reply
More about radeon x1950 iceq warcraft
  1. Try Catalyst 9.3.

    That seems to work best for the Radeon X1950 series and Win 7.
  2. Thanks, so to uninstall the drivers I just go to device manager, hit uninstall, then install that?
  3. That's it.
  4. Ok, I just installed catalyst 9.3 but then it gave me the error, no ATi drivers installed or it is not working properly, try installing the proper drives. Then when I restarted windows did an auto install of the most updated drivers, I have to figure out how to disable that.
  5. Try reinstalling Catalyst 9.3 now or is that what it installed?
  6. No, when I go to the video card in device manager it says (microsoft corp - WDDM)
  7. 32 or 64 bit Win 7?
  8. 32 bit
  9. Give 9.8 a shot it might work and is what I use on my x1900xt. I use it to play wow and do online stuff. As for wow I get a steady 75fps with only a meager athlon 64 3500+ am2. Good luck with your x1950 pro.
  10. nforce4max said:
    Give 9.8 a shot it might work and is what I use on my x1900xt. I use it to play wow and do online stuff. As for wow I get a steady 75fps with only a meager athlon 64 3500+ am2. Good luck with your x1950 pro.

    Check your CCC, I don't think you're using 9.8. All DX9 cards are reverted to legacy support at 9.3. Check the fine print.

    http://support.amd.com/us/gpudownload/windows/Legacy/Pages/radeonaiw_vista32.aspx?type=2.4.1&product=2.4.1.3.13&lang=English
  11. every time I reinstall ccc, and try to open it, I get an hour glass but then nothing happens, any idea on this?
  12. Try opening it from the program list in the start menu instead.
Ask a new question

Read More

Radeon Graphics