Sign in with
Sign up | Sign in
Your question
Solved

Power surge fry the mobo?

Last response: in Motherboards
Share
April 7, 2010 3:40:07 PM


I had a fully functional new build, then I turned on my A/C and noticed a few minutes later that my monitor was blank. After force reboot, the system won't even post and reboots after a couple seconds of being powered on! I'm very sad I didn't get a surge protector first. I tried striping out everything (including video card, all memory, all PCI devices) and I pulled out the mobo and put it on cardboard.

I have to imagine I fried something, right? ...unless it coincidentally happened the same time (roughly) when I powered the A/C.

How can I tell what I fried? Was it the CPU, mobo, or PSU? I should mention I don't have spare of anything to swap in/out.

More about : power surge fry mobo

a c 78 V Motherboard
April 8, 2010 12:25:28 AM

First, get a surge protector, then get a working PSU with at least as much power as your old one. Then set up your rig on the breadboard (the cardboard). Assemble it and, check the power and data cables to make sure all are properly connected. Power-on. If it works, your old PSU probably saved you. It is worth trying a new PSU first because many of today's PSU's have circuits designed to blow the PSU before they blow the system.

If replacing the PSU does not work, this could become time-consuming and expensive: Since you don't have spares, or other means to test your components, you would need to get replacement components 1 x 1 starting with the motherboard, CPU, RAM, GPU, HDD, and re-test each. Or, you could build a new rig around the new PSU.
m
0
l
April 8, 2010 9:40:19 PM

Tried a new PSU, no dice - same exact behavior. I'm going to test a new CPU and mobo...

Any danger I might fry a new CPU if the mobo is faulty?
m
0
l
Related resources

Best solution

April 8, 2010 10:37:28 PM

If it's a fresh build, you're probably fine. Just don't mention the A/C thing to an RMA department.

If you're getting fan and LED activity, pull the video card and RAM. If you don't get any beep codes, it's likely a fried mobo (likely) or you don't have a PC speaker equipped (unlikely) on the board. It could also be a blown 12v rail on the PSU, but that's rather unlikely in my opinion. You didn't list the board model, so I can't give you information on what beep codes to expect to hear.

If you get beep codes with video card and RAM removed, then install the RAM. You should get a different series of beep codes. If you made it that far, the mobo is probably fine.

Keep us updated.
Share
April 8, 2010 10:40:15 PM

Best answer selected by mariod505.
m
0
l
April 8, 2010 10:42:04 PM

Turned out to be the motherboard. I put the CPU into the new motherboard I just bought and it works great.

You think Newegg will take it back with the retail box of the new one I just bought? I foolishly threw out the first box. :/ 
m
0
l
April 9, 2010 2:46:39 PM

Maybe. If your invoice doesn't list a S/N, you're probably fine. However, you'd need that box to do a return at the brick & mortar store you just visited.

My recommendation would be to contact Newegg and see if they can give a same-model replacement of the defective board sans box, then return the B&M one when the egg board tests good.
m
0
l
!