Sign in with
Sign up | Sign in
Your question

2500k & ECS P67H2-A2 - Help!

Last response: in Overclocking
Share
February 5, 2012 1:35:07 PM

I think I may actually be going insane.

Let me start by saying that, while I am by no means an expert, I've overclocked my fair share of cpus over the years. However, I'm completely stumped here, and would love a little insight.

I recently upgraded my rig to include an i5 2500k and an EliteGroup P67H2-A2. I've been trying for several days and scouring the web for answers, but I cannot seem to overclock my cpu. At all. No matter what multiplier I choose, it always boots to 33x. I can choose 40x to try to get to 4.0GHz and it boots to 3.3GHz. I can choose 20x, and it boots to 3.3GHZ. Nothing seems to work.

I've read several guides, including the ones on Tom's, and followed them step by step, but to no avail. I've disabled/enabled everything I can think of in the M.I.B. III section of the BIOS, including the ICC configuration section. I've even tried several overclocking softwares, such as Intel's XTU, and ECS's eOC. Nothing has worked.

I would greatly appreciate any help you can provide. Hopefully there is a simple setting in the BIOS that I have over-looked. Thanks!!

More about : 2500k ecs p67h2

February 6, 2012 1:37:03 AM

Well, I fixed the problem on my own. I decided to flash the BIOS to an earlier version, and now I'm cruising at 4.5Ghz. Just thought I'd let you guys know in case anyone else runs into this problem.
m
0
l
a c 172 à CPUs
a c 197 K Overclocking
February 6, 2012 2:18:43 AM

I do not want to sound snarky, but most overclockers will not run into that problem. In general, we try to avoid ECS motherboards. :) 

But congratulations on solving the problem on your own.
m
0
l
!