Sign in with
Sign up | Sign in
Your question
Solved

Cannot disable DrectDraw? - Win 7 / ATI drivers

Last response: in Graphics & Displays
Share
October 29, 2009 5:49:10 PM


Windows 7 Ultimate 32 bit
Sapphire 4870 X2 latest drivers from ATI

Is there a way to disable DirectDraw/Direct3D acceleration? Windows XP allowed that through dxdiag but all the options to do so are greyed out in Windows 7. Same with the regular Display options of the OS. Please see this for screenshots:

http://www.sevenforums.com/general [...] ation.html

Is there a way to do this through the catalyst control center?

Is there a set of older drivers that would allow me to tweak this stuff?

I just made the jump from XP finally but I am already regretting it
October 29, 2009 5:59:50 PM

why do u want to disable DirectDraw??
October 29, 2009 11:07:48 PM

Why the heck would you want to do that???
There's no point in having a graphics card in the first place if you do that :heink: 
Related resources
November 10, 2009 11:22:00 AM

Been away for a while.

There are a lot of reasons to want software acceleration over hardware. Not sure why you care, but in this particular case I want to get an old game to work, which does not support new video cards. A couple tweaks gets it to work on my WInXP OS but I am trying to move onto win7, for good. Can't stand having to dual boot. And I would not like to give up on 7.

I just do not get why Windows 7 does not allow to turn DD off. Windows XP conveniently supported user input in this. Does Win7 need direct draw for its GUI?

Best solution

November 10, 2009 8:11:29 PM
Share

Actually yes it does. Microsoft decided to make it a truly integral part of the OS again.
November 23, 2009 9:27:09 PM

No way to disable it then.

Thanks for confirming :sweat: 
November 23, 2009 9:29:36 PM

If you don't mind my asking what game is it you're having trouble with?
July 19, 2010 8:00:35 PM

It's been months and I am giving this another try.

The game is Might and Magic 7.

Still having tons of issues though.
July 20, 2010 1:10:35 AM

I doubt turning off DirectDraw even if it was possible would help.
Have you tried Windows Xp or 98 compatibility modes?
!