Sign in with
Sign up | Sign in
Your question

2X4890 xFire performance is terrible Plz Help

Tags:
  • Radeon
  • Performance
  • Graphics
Last response: in Graphics & Displays
Share
October 30, 2009 3:12:43 PM

Ive been struggling with xFire performance on 2 different m/boards now; the first one was a Biostar TPower i45 and my latest system is PSU: Crsair TX750w; CPU: Intel i7 860; M/Brd: Gigabyte P55 UD4; DDR3: 2x2GB GSkill RipJaw pc3 16000 2000mhz; GFX: 1xASUS HD4890 + 1xXFX HD4890; Monitor: Samsung sync master 23` res 1920x1080; This is the system i will be using for the foreseeable future.

The problem im having is that each of my cards are giving me about 27 - 33 fps when installed singly but when installed together in xFire im getting 17 - 19 fps when i should really be getting about 45 fps and this is with xfire enables in ccc. I did have problems actually getting xfire to work so i tried different drivers and 9:6 seemed to work otherwise xfire option would be absent in ccc. I have tried removing the cmos battery for 30 secs, loading optimized settings in bios, ive uninstalled & reinstalled drivers and cleaned up with driver sweeper, ive installed both cards together and tried one at a time(i managed to get 9:10 to show the xfire option in ccc using this last method) and ive just about tried every option that ppl have thrown at me. I am now seriously disillusioned with xFire.

Im sure this problem is unique to the 4890 and driver compatibility issues and im hoping that someone at Toms will have some knowledge about this problem enough to help me, otherwise i have wasted a lot of money on a card that is effectively useless for anything other than as a back up.

More about : 2x4890 xfire performance terrible plz

October 30, 2009 3:30:02 PM

I am the same way with sli but it wasn't the cards them selves but it was overhead with the fsb on my 780i. If you are not overclocking your cpu set the ram to manufacturer's specifications and tweak it a little then post what you get then.
October 30, 2009 3:54:31 PM

Well you're mixing brands, and while they're the same cards they have different core and memory clock speeds. Trying normalizing them to one speed and see if that helps, because I'm not sure if CrossFire does that automatically since they're both the same reference.

Firstly, are you using two CrossFire bridge connectors to merge the cards in your case? A lot of people forget and only use one which isn't enough and causes performance issues.

Secondly, overclock your CPU and memory. While hypothetically you should be fine as both your CPU and memory are good, it couldn't hurt to try. Tighten up your timings on the DDR3 1600 to 7-7-7-20 or 21 if possible. If not, try downclocking it down to 1333 and doing the same.

Lastly, do some searches on whatever search engine you use like "HD 4890 CrossFire performance" or "HD 4890 CrossFire problems"; you get the point. Also, if nothing works, post a support topic in the AMD/ATi forums, they would know better than anyone, and you may even get an official representative to help.
Related resources
October 30, 2009 7:40:35 PM

Thanx for the help guys, i have messed around with the clock timings a little, where it set itself to 9 9 9 24 on auto i have set it to recomended settings of 9 9 9 27 but its worse now than it was before, now im getting 16fps :fou: 

And Brock i bought my 2nd card the XFX to do xfire with so i checked they are exactly the same GPU clock speed and mem frequency and both HD. This is baffling because ive spoke to other ppl on forums and they say i should be competing with the high end cards but i cant even compete with 1 4850 and this problem has been here before i upgraded all my components and its really doing my head in so im off to the ATI forums to get this sorted once and for all.

Cheerz guys
October 30, 2009 7:45:02 PM

Try 8 8 8 20 and see what happens next been down this road and have to tweak all the time on my rig.
October 30, 2009 8:07:00 PM

Stiffex said:
Thanx for the help guys, i have messed around with the clock timings a little, where it set itself to 9 9 9 24 on auto i have set it to recomended settings of 9 9 9 27 but its worse now than it was before, now im getting 16fps :fou: 

And Brock i bought my 2nd card the XFX to do xfire with so i checked they are exactly the same GPU clock speed and mem frequency and both HD. This is baffling because ive spoke to other ppl on forums and they say i should be competing with the high end cards but i cant even compete with 1 4850 and this problem has been here before i upgraded all my components and its really doing my head in so im off to the ATI forums to get this sorted once and for all.

Cheerz guys


Why are you setting your ram timings slower than they were before? The lower the numbers, the faster the memory. Set them to 8-8-8-24 or 7-7-7-20/21; whichever works. Are you using two CrossFire bridge connectors?
!