Sign in with
Sign up | Sign in
Your question

Boot problem with Sapphire Vapor-X Radeon 4890 2gb.

Last response: in Graphics & Displays
Share
October 30, 2009 9:33:58 PM

Hey all,

I got sort of a problem with my new Radeon 4890 card. Got it today and when I try to boot the computer, the monitor just turns blank and the computer wont boot. All I get is "check signal cable". It runs perfectly fine when I chuck my old graphics card (GeForce 8500 GT) in and go with the same cables (VGA with a VGA to DVI-I adapter). What happens is that the new Radeon just goes to max fan speed, making a hell-of-a-lot of noise and then nothing. Lights on the Radeon 4890 are on and it seem to be working properly. I connected my power supply (Corsair TX650w) to the Radeon 4890, but the Radeon got 2 different slots (one 2x3 pins and one 2x4 pins) and as the power supply I have got some pins which says PCI-E on it, and matched the 2x3 slot I figured that was the way to go. Not sure if it's the right one though so please feel free to correct me.

Anyway, my spec is as follows;

Motherboard: Asus p5n-d
Memory: 2x2gb corsair ddr2 sdram
CPU: Intel Core 2 Quad Q9550
Monitor: Samsung SyncMaster 2032bw
PSU: Corsair tx650w
Old GPU: GeForce 8500 GT
New GPU: Radeon 4890 2gb

So I really don't know what the problem is. As I mentioned, I don't even get it to boot far enough to get to the bios. The GPU fan just goes nuts and nothing happens. I tried to problemshoot as much as I could. I removed 1 of my 2 RAM to no avail, also reset my bios to default (not done the clean sweep you do on the motherboard though, as I have no idea how to do it), checked with and without my VGA to DVI-I adapter, my HDMI to DVI-I adapter etc etc. I'm unsure if the cables are the problem though, as I'm running the CPU now with my old GPU with the VGA to DVI-I adapter and it works fine.

So please, if anybody had any similar problem, or any idea, please let me know. I'm sorry if my description of the problem is a bit messy, but if anything is unclear, just ask and I'll try to explain it in more transparent terms. Thanks.
October 30, 2009 11:12:08 PM

Problem solved. I apparently had to connect both power connectors to the graphics card. Here I was thinking that there were 2 different so the user could choose which one to use.
!