Sign in with
Sign up | Sign in
Your question
Solved

SSD as cache for 1TB disk, got bsod, then can't see C: Drive. Help!!

Last response: in Storage
Share
September 5, 2011 11:29:55 AM

Hello all!

For the past few days I've done extensive research searching on google for an answer and tried a few solutions in vain. Hope this is the right community for an answer.

None of the popular solution using Bootrec or even EasyBCD works...

PC Config:
- Windows 7 64bit, AsRock Z68 Extreme4 Intel i7-2600k CPU.
- Western Digital 1TB BLUE SATA III cached (os & data) on a 40GB Intel SSD

This single partition setup cached on SSD in now unable to boot after a few BSOD that says "DRIVER_POWER_STATE_FAILURE *** STOP: 0x0000009F (0x00....)

Upon boot-up, it goes to Windows Boot Manager (DOS screen), with an error: Windows failed to start....
File: \Boot\BCD
Status: 0xc000000f
Info: An error occured while attempting to read the boot configuration data.


I tried booting to Repair Disk and onto command prompt to run bootrec, but the main problem is that the C: Drive is not found! It can't find any windows instances too (because drive is not found, I presume). I even paid for EasyBCD in a rush but only to discover I need to run it from within Windows?!

I then tried booting off from a CD into ubuntu o/s, which can see my HDD as a 1TB mount point, I can access the data and copy out to a USB drive, however, I discover that NOT ALL DATA are there!

Noticeably, all my media files which I stored in Windows Libraries are NOT FOUND. I searched the whole volume with known filenames of my photos, but the media folders are empty, and I can't find those subfolders anywhere else.

The used space report on the volume is 667GB out of 1TB, which I felt it fall short.

Questions floating in my mind are:

1) Are those missing files stored in my SSD? Which is used as a cacheon this 1TB volume (os + data).

2) From the command prompt, I can't see the C: Drive, what does it mean?

3) When I access this volume from ubuntu, am I accessing through the SSD cache too? Or does it go straight to the physical harddisk by passing the SSD?

4) Are there still hope for me to boot up my PC and get back into Windows 7 to recover my media files?

Thanks a million... Hans
September 5, 2011 3:28:23 PM

As to why I can't see the "C Drive" at the recovery command prompt, is it due to the RAID setup between the SSD and the HDD? The BIOS can detect the RAID Volume as follows when it starts up:

Intel Rapid Storage Technology - Option ROM - 10.5.0.1034

RAID:

ID :1
Volume Nam: Volume_0000
Level: RAID0 (Cache)
Strip: 128KB
Size: 37.3GB
Status: Normal
Bootable: No


Physical Devices:

Port 0: WDC WD10EALX-009
Size: 931.5GB
Type: Non-RAID Disk
* Accelerated Disk

Port 1: INTEL SSDSA2Ct04
Size: 37.2GB
Type: Cache Disk(1)


What drivers can I load to allow me to view the RAID as a C Drive? Or is this the reason why I can't see it a command prompt?


m
0
l
September 6, 2011 3:44:53 AM

Any help at all?

Further question: If I boot this system from the ubuntu o/s CD and access the HDD, is the SRT Cache on SSD effective? Or am I by-passing the cache this way?

Since the BIOS can recognize the SSD as cache, are there still any drivers needed before I can see the complete data?
m
0
l
September 8, 2011 10:07:54 PM

That looks like an Intel 320, so I'd guess you've hit the bug where it magically decides it's only an 8MB disk.

No idea whether you can recover from it; this is one reason why I don't like consumer-grade 'performance boosting' technologies like this.
m
0
l

Best solution

a c 82 G Storage
September 9, 2011 1:57:05 AM

prosumer said:
Any help at all?

Further question: If I boot this system from the ubuntu o/s CD and access the HDD, is the SRT Cache on SSD effective? Or am I by-passing the cache this way?

Since the BIOS can recognize the SSD as cache, are there still any drivers needed before I can see the complete data?

Can't you disable SRT or disconnect the SSD? A caching SSD stores copies of frequently used files on the hard disk; it doesn't move them from the hard disk to the SSD.

Intel allows two modes of write caching: enhanced and maximized. Which one was configured?

How did that issue start? Did the system crash?
Share
September 9, 2011 6:11:33 AM

Thanks GhislainG, you know what? Simple as your suggestion is, that seems to be the solution!

I did something difference but with same logic; I disconnected the HDD and docked it with a USB HDD dock to read off another Windows PC. Still can't locate those "missing folders" I suspected got cached in the SSD, but I when I click on the parent folder which contains them, it reported "corrupted".

So I held my breath and did a simple CHKDSK... it fixed the directory problem and those missing folders are back!!!! :pt1cable: 

My SRT was in Enhanced Mode.

What made me paraniod were mainly:
1) the "C: Drive" is not there at command prompt booting from recovery disk. So I was search hi-lo for some kind of drivers to load so as to see this cache+HDD instance, before I can apply any of those BCD fixes or CHKDSK.

2) the missing folders in the HDD, when browsed from a lunix boot disk, did not reported that the parent folder is "corrupted", and there's no similar CHKDSK in lunix. These folders sized around 40GB too...

So! Taking out the physical HDD and running a simple CHKDSK recovered my precious folders! I'm making DVD backups of them now! Thank God!


p.s. I didn't think of removing/disabling the cache then, as I can't be sure SRT do have the latest copies of the files in the HDD when it "cache" it in RAID 0 (strip 128KB) - it's not RAID 1 mirroring so I didn't think the cached data is in HDD too. I read so much about how SRT works in "blocks" of data, and how "smart" it is not to flush the cache for performance reason, etc.

p.s.2 @MarkG, Nay, it's not the 320 SSD 8MB bug... the bios reported 37.2GB all along. I posted in other forums and everyone think this is the cause just because it's popular now. My case is just a simple folder structure corruption due to a BSOD and then can't see the "C: Drive" (which is the only thing I'm still puzzled)

p.s.3 I sure hope this thread will help someone else hitting boot issue when running SRT cache!


Final note: NO MORE INTEL SRT FOR ME !!!!! THANK YOU!
m
0
l
September 16, 2011 4:52:21 AM

Best answer selected by prosumer.
m
0
l
September 16, 2011 5:02:48 AM

Further update:

While my missing folder structures and files were recovered, there are a quite number of files corrupted. E.g. jpg & video files that cannot be open anymore. I suspect this must be the damages given that some "blocks" of cache data not sync with the HDD, maybe.

Certainly, I didn't expect 100% recovery from a direct access to the HDD in such a cache setup. Something ought to be still in the cache at the time of the incident. :sarcastic: 

m
0
l
a c 82 G Storage
September 16, 2011 10:51:48 AM

Regular backups on an external device still is the best protection.
m
0
l
September 16, 2011 11:12:27 AM

Yes, no excuses for not having backups :ange: 

However, even if I do have a full system image of the windows o/s, I'm just not sure how I can recover the image without first getting the C:D rive (with SSD cache) working first; without risking formating the HDD during the disable-cache & re-enable cache stage. So again, my personal view is that caching with SSD is a flop when it comes to unpredicted BSOD which can happen anytime.
m
0
l
!