Sign in with
Sign up | Sign in
Your question

Make disk be Disk 0 in Disk Management

Last response: in Storage
Share
September 5, 2011 1:37:17 PM

Can anyone tell me how to make a disk be "Disk 0" in Disk Management?

I'm trying to upgrade firmware on a 128GB Falcon II SSD. Apparently this can only be done if the SSD is listed as Disk 0 in Disk Management.

I have OS installed on the Falcon II disk.
I have mirror of falcon disk on and IDE drive.

I need to be able to boot from the mirror on the IDE drive so I can do the firmware ugrade on the SSD.

When I set boot priority in BIOS for the IDE to boot ahead of the SSD, the IDE drive becomes Disk 0 in Disk Management...

Is the BIOS boot sequence the only way to change assigned Disk #s in Disk Management???

How can I get this SSD to be Disk 0 and still boot from the IDE drive?

Thanks for any help with this!
a c 82 G Storage
September 5, 2011 5:23:40 PM

Is the SSD connected to the first SATA port?
m
0
l
September 5, 2011 6:15:07 PM

Thanks for the response.

There are 8 SATA ports on the MOBO (an MSI P55A-55G)...#'s 7 and 8 are supported by a Marvel driver which supposedly goes up to speed of 6.0Gb/s.

DVD reader on port #1
DVD writer on port #2
SSD is on port #7...the first of the two supported by the Marvel driver...

2 identical IDE disk drives on the IDE cable...the first of which has the clone of the SSD I want to use to run the software for firmware update...
m
0
l
Related resources
a c 82 G Storage
September 5, 2011 8:23:25 PM

As far as I'm concerned the SSD has to be connected where the CD reader is (first port). You should then be able to flash it.
m
0
l
a c 415 G Storage
September 6, 2011 12:51:27 AM

^+1

The disk "numbers" shown by Disk Management are based on the order that the drives are enumerated at startup, which in turn depends on what controller / which port they're connected to. The device attached to the first port on the first controller should be assigned the "0" number.
m
0
l
September 6, 2011 10:35:26 AM

K...thanks for the replies guys...

I'll try switching the SSD to SATA port 1 and see what happens but I know that I've seen the "Disk 0" listed in Disk Management switch between the SSD on SATA port 7 and the IDE drive just based on which boot priority I set in the BIOS...without changing the physical connection of either drive...

The only other setting that I played with in the BIOS was the Integrated Peripherals setting for SATA to either IDE or AHCI. I suppose this may be where I'm causing the "Disk 0" change as I don't really know precisely what that setting is changing...only that AHCI seems to be the preferred setting for SSDs used for Windows 7 installations.

(The firmware upgrade instructions at GSkill are brutal)

Thanks again for the input guys!
I'm on nightshifts now but as soon as I have time to try to work this out again I'll report back the results.
m
0
l
a c 82 G Storage
September 6, 2011 11:35:42 AM

If need be, make the SSD the boot disk and boot from an alternate device if need be. As with most motherboards, a function key should allow you to select the boot device at POST.
m
0
l
September 6, 2011 12:06:07 PM

K...without setting boot priority for the SSD drive the system wants to set the Disk #'s starting with the IDEs

tried removing the IDEs and booting from a clone of the OS on an external USB drive...no go...won't boot from it...

Tried web search to figure out the function key for an MSI board to select boot device at post...no luck...I think this might work if I can figure out which function key...gotta sleep now but I'll try again tomorrow...


Thanks again for input guys!
m
0
l
September 14, 2011 12:36:40 PM

K...

The only way I was able to get the SSD SATA drive listed as "Disk 0" was to remove the two IDE drives...nothing else worked (SATA port 1 made no difference...IDE disks take priority in the disk numbering).

I was able to boot the system from a boot disk after removing the IDE drives and then do the SSD firmware update.

Thanks all for your input with this issue!


Oh...and it was F11 to get to boot device selection at post on my MSI mobo if anyone is trying to figure that out...
m
0
l
!