Sign in with
Sign up | Sign in
Your question

Windows 7 upgrade killed crossfire/disabled adapter #2

Last response: in Graphics & Displays
Share
November 1, 2009 12:31:57 AM

I just upgraded to Win7/x64 on my XPS 630i. I have dual HD 4870's which ran great in Xfire until I ran the OS upgrade. Now my second adapter is disabled and there isn't even a Crossfire option in CCC. Anyone else see this? I've tried the newest driver (9.10) and have gone back as far as 9.7 but nothing has helped yet.
November 1, 2009 3:58:32 AM

First try card 2 in slot 1 to ensure both cards are in fact working. Second completely un-install all the graphic drivers and re-install the lastest version. If there's no change in your system you should consider backing up all your data and doing a complete install of windows 7. Does upgraded mean you did an in place upgrade to windows vista 64? As this would not be my first choice. Assuming you have an upgrade version of windows 7, you do know you can do a clean install by selecting "custom install" instead of upgrade? I would remove the 2nd video card until after the installation, because I want to be sure the system recognizes the 2nd card, then reinstall the catalyst drivers. Good luck
m
0
l
a b $ Windows 7
November 1, 2009 4:48:21 AM

This is what I love aboutDELL fand their inability to do real upates.......lol
First off you need to have the win7/64bit motherboard drivers...save them on a jump drive.
Now install the os, then run the motherboard drivers from the jump drive.
After that get the updates from windows....then install the win7/x64 ati drivers.
You'll have to reboot a couple of times but when you're done go into the driver settings and activate the crossfire........and you should be good as gold!....JQ
m
0
l
Related resources
November 1, 2009 10:44:42 AM

Thanks to you both. I knew better than to trust an in-place upgrade, but my wife was working on something and wanted to be back up quick so I tried it... I have verified both cards work by disabling them one at a time and successfully using each one. The strange part is that CCC and GPU-Z show the second card as disabled, but device manager shows them as both active. I threw this issue at Dell also, waiting to see what kind of useless canned response I get. I'll continue posting updates as I go in case anyone has this same issue (I know others are getting it from various forums but no solution has appeared yet).
m
0
l
November 1, 2009 11:51:05 PM

UPDATE: for the time being I've gone back to the v8.55 drivers that came with the system, and everything is working again. But I raised holy hell with Dell and basically told them that if they aren't going to develop a more recent ATI driver that will work with this motherboard, they need to replace my cards with comparable GeForce hardware. We'll see where that goes...
m
0
l
November 2, 2009 12:04:12 AM

Only problem is if you have a crossfire mobo, then probably no sli on that board.
m
0
l
April 16, 2010 12:32:43 AM

Found a solution to my problem on Asus P5K Premium WiFi. The universal PCIe slot will run at only x1 mode with other PCIe slot(s) are used. I removed my Xonar PCIe sound card and the EAH2600XT graphic card from the primary PCIe x 16 slot. Booted up and uninstalled all ATI Catalyst software. Rebooted and reinstalled ATI software. Shut down. Added 2nd card and attached DVI monitor graphic card now in primary PCIe x16 slot. Booted up and got option to enable crossfire. Now 2nd card shows as Linked adapter.
m
0
l
Anonymous
a b $ Windows 7
May 19, 2010 3:49:28 PM

Hi,


Go to supportdell.com choose to install drivers but dont put in your service tag choose xps and then 630i you will then need to install dells original drivers this should activate it you will then need to uninstall all these drivers you got from dell and go to ati.com and install the latest drivers once the system rebootsafter installing it should then reconize crossfire for the 4870 and lower end card.
m
0
l
!