Sign in with
Sign up | Sign in
Your question

CMOS battery dead, boot failure. Is my raid 0 gone?

Last response: in Components
Share
January 8, 2010 2:35:38 AM

Yesterday I was running the computer normally and suddenly there was a power failure in the building so everything went black.
When power was back on I could not boot computer. This is very strange cause over the years I have seen multiple power failure while using pc's and I have never seen anything like this. Also I do take some precaution even not running full UPS I run a Belkin SergeMaster.

Booting now takes me to a new splash screen so maybe Bios is resetted as well? I got an cmos error msg and turns out battery is now dead and time and date is wrong.
It seems I'll have the options to keep pushing for normal boot and ignore the error message, but I am afraid to try cause that might make things worse for my raid 0 drives. Remember more then 1TB of data is stored on those drives (without any existing backup) and I really would love to be able to get them over to a raid 5 nas now.

What about information about the raid, are information like that kept in Bios or on the actual hard drives? As I don't have a dedicated hardware raid controller card I would think all information about the array and the data would be in the boot sector of the drives and so possible to retrieve?

Will I be able to just switch battery with any motherboard from same vendor? (live in rural erea, and battery will not be here before monday @ the earliest)

To recap quickly:
No 1: Will faulty battery in anyway be destroy my raid?
No 2: Is it possible to move the raid to another computer and still save data?
No 3: All important data is in my Home folder in Xubuntu including virtual machines so even if not possible to boot raid on another pc maybe possible to read my home partition?


Hardware:
I run Xubuntu 8.04 LTS 64 bit.
Asus P5N-E SLI, nF-650i Mother board
Core 2 Quad 6600
4 x WD caviar in raid 0 using onboard controller (software raid i belive)

And yes now I know. Backup DOES rule :cry: 
January 8, 2010 2:41:07 AM

Btw when I go in the setup I can see all 4 HDD showing up and no faulty error message placed next to them, so disks are alive still.
January 8, 2010 4:46:00 AM

You need to restore your bios settings to what they were. Assuming pow surge did not bust anything. Or get the bios settings close anyway.

if the hdd's show up, you are ok to that point - but if something else blew - well, you will find out when you boot it, and if it won't, good luck.

btw I don't know linux. yet. i am simply assuming everything is ok from the surge.
Related resources
January 8, 2010 7:59:30 AM

Ohh. That is not good news. Restore Bios settings. I have no idea how I set up this cause the setup was done fall 2008. I can not at all remember if I have changed anything, or whatever data I should put there for the raid 0.

Is there anyway around this matter?

If I take pc to a shop, would a technician possible be able to solve a matter like this? (Not to step on anyones toe here but from earlier experiences I know many of are way to quick to hold format C: as the mother of all solution)
January 8, 2010 8:24:20 AM

Several comments:
1. A surge suppressor is no substitute for a UPS. If you have the kind of unstable power you say you have, you really should have one.

2. Everyone should have a notebook documenting his systems - serial numbers, parts, BIOS settings, upgrades. Mine has six tabs: 4 for desktop systems and 2 for notebooks. Yes, it's a little more work, but you have the data if you need it.

3. You have a software RAID system. One of the "gotcha's" is that a software RAID system is specifically hardware dependent on the system that generated it. That means that if your motherboard dies, your best bet is an identical motherboard. After that, the odds of a successful recovery start dropping quickly.
January 8, 2010 9:09:51 AM

http://asus.com/product.aspx?P_ID=KyHOsOKWujC2QguJ&temp...

Chuck in a new bios battery and boot into the bios.

I asume you havn't moved the SATA connectors from the red sockets for the two drives you have in RAID0?

Yes a techy can sort this one quickly - I would assume you would have set the array up with default paramenters anyway.

I tend to use smaller chunks for my raid0 sets than thay suggest.

Set the Stripe to 16kb, or 32kb. The larger you set the kb, the faster your raid will be BUT the larger you set the kb the less efficient use of hard drive space.

Your bios will have a default setting I imagine so leave it.



January 8, 2010 9:58:26 AM

Thank you reynod. You are correct, I have not touched any of the SATA conectors. They are all placed in their allocated sockets. Btw I run a 4 drives raid not 2 not sure if that matters.

If my faded memory serves me right I use 64 kb stripe.

I have another pc running another Asus motherboard. Plain and simple setup with singel drive. So wil it be possible to nick the battery from that and replace the faulty one so I at least can get all my data onto to a Nas?
January 8, 2010 10:05:58 AM

jsc said:
Several comments:
1. A surge suppressor is no substitute for a UPS. If you have the kind of unstable power you say you have, you really should have one.

2. Everyone should have a notebook documenting his systems - serial numbers, parts, BIOS settings, upgrades. Mine has six tabs: 4 for desktop systems and 2 for notebooks. Yes, it's a little more work, but you have the data if you need it.

3. You have a software RAID system. One of the "gotcha's" is that a software RAID system is specifically hardware dependent on the system that generated it. That means that if your motherboard dies, your best bet is an identical motherboard. After that, the odds of a successful recovery start dropping quickly.



1. Noted a UPS is now in order and during next week will be installed.
2. Great idea, from now on I will use this and even include a Bios backup :) 
3.1. So there are no way I could move the raid onto another computer that is not 100 % similar?
3.2. So the onboard raid is a hoax really? Luring people to rely on consumer grade hardware. Do you recommend going all the way from now going for a truly hardware raid with dedicated controller with it's own cpu?
December 5, 2010 4:20:00 PM

I have similar problem.
I also have Asus P5N-E SLI motherboard.
I also have 4 HDD running raid 0.
All SATA connectors are still plugged in and have not been removed.
I can see all drives from BIOS so drive health seems ok.

I am no computer wizard and I had hired help to set up this computer when I first bought it. Unfortunatly I didnt understand the risk of raid or nor the importance of regular backup. Which is why I am standing here crying today with the possibilites of loosing all of my importent data.

But the problem for me is that I never did make any different partions on the raid setup (is this referred to as array?) So I am scared to loose all my data from the raid if I keep pushing for boot.

I do see people ment that restoring BIOS will enable raid and make boot possible.

  • But does resetting BIOS do anything to the boot sector of the harddrives?
  • I do not need to be able to restore raid completly, all I need is to collect importent data.
  • All importent data is stored in a folder that I shared on my homenetwork, so I might not even need to boot up completly to be able to reach data from another connected pc?
  • Is there any things I must be extra carefull not to touch or change while in BIOS making sure I not ruin the raid setup?

    I think the most difficult thing I have done while in bios is to change boot order and enable faster boot without all things checked before booting. So I need help in a very detailed manner if possible.

    Are the BIOS screens of all Asus motherboard the same? With the same menues and submenues?
    If so could someone make print screen and post so I know where I should enter to make changes and what chnges I need to enter. I have no clue how the raid was setup in the first place. Is there many different choiches on get when trying to reset BIOS?
    December 5, 2010 11:12:57 PM

    Btw this is what happend the day of break down.
    I was just done copying some photos from camera and over to pc.
    I need to plug in an electric component and I was sure i unplugged the screen. Turned out
    I unplugged the pc and after that I can not boot pc.

    Is there any danger of destroying the raid if I make changes in the BIOS the way original poster did?

    Is there any tutorials on BIOS setting for this motherboard?
    December 9, 2010 11:27:52 PM

    Come on. Someone ought to know how the BIOS and raid settings works.
    If anyone have a similar motherboard maybe they can look into the raid settings?
    I dont dare to play around with anything cause I fear I might make matters worse.
    Need help pls.
    January 3, 2011 10:46:45 PM

    Little help here pls.
    I dont understand much of the bios or raid setup. I need help if I shall ever get to my data.
    I have looked around alot but I am afraid to destroy things even more.

    This is the raid settings: (note that this is not actually my drives but things look the same.


    What is raid 0? Mirror or stripe?

    Before I was running raid 0. Then power went out and it became impossible to boot. People tell me to fix the settings but I dont know how to be sure I put in correct values. If I make wrong maybe all data will be destroyed?

    If I add all the 4 drives like they have done with two drives in this pic below, what else do I need to fix?
    What about striping block? I dont know/remember what block I once chose when this was set up in the first place. Can something break even more if I put Optimal and it turns out I should hav edifferent value?


    What to do here? Remember these drives have been running in raid 0 before bootfailure/powerout.
    If I choose NOT TO CLEAR DISK DATA will raid work when saved?



    These pictures I have nicked from this raid tutorial

    What else to say? I have all physical correct settings if SATA also uses jumpers cause this raid 0 was running perfectly before power was out. After power loss no more boot.

    Pls help me out here, I really need to collect data.


    January 3, 2011 11:24:13 PM

    This is hard. Well I figured out that setting Raid Mode to Striping was equal raid 0.
    So I did that and also put added the 4 drives like in the turorial. I chose Not to Clear Disk Data,
    and my raid look like this: (excpet 4 drives) Assuming it was all OK, like it says Healthy.


    I did forget to set it to Boot so I exited and tried to boot. I got a Grub loading Error 2.

    Went ahead back in and changed to Boot.

    Rebooted and still the same Error 2. Now I am very scared. Have I broken everything?
    Pls help me here before I get so nervous I pull my hair out and chew up my fingernails.

    Edited:
    As I read up it seems that maybe software raid is trying to put disk in one order and Grub in another.
    I have no idea what order they are supposed to be in. After all none of the cables have been removed. Alle disks have been in place in pc. I still have hopes that there is fix for this.
    January 3, 2011 11:33:31 PM

    I did run raid 0. And as I am learning now that was not the best choice as I had no regular beckups.
    I read on ubuntuforums that changing away from DMA in BIOS have helped others. What is DMA and do I break things if I try that setting?
    January 3, 2011 11:41:10 PM

    I am running ubuntu. Hmm cant find any disk that came with the bios.
    But I did notcie there are two bios's on the mobo. I am still reading in panic everything I can find on error 2 but it is not making me see the light yet.
    January 3, 2011 11:44:48 PM

    Cant think of anything that might cause this either. All 4 drives I can see in BIOS. In raid settings they appear to be jolly. Even when I set up raid again it says that it is healthy. Why will things not work? Frustrated.......
    January 3, 2011 11:54:01 PM

    Going back into NVRaid utility I can read these details:
    Raid Mode : Striping
    Striping width: 4
    Striping block: 64K

    1. Port Index Disk model Capacity
    2. 2 0 ST3350032ons 465.76GB
    3. 3 1 ST3350032ons 465.76GB
    4. 4 2 ST33750033ons 698.63GB
    5. 5 3 ST33750033ons 698.63GB


    Dont know if this make any sense. But I do remember I used two pair of drives when setting this up in the first place, hence the variety in capacity and disk model.
    January 4, 2011 12:07:08 AM

    I am loosing hope here. Seems this is too much for me.
    Looking at this webpage it seems for some reason that this is my issue:

    Quote:
    GRUB Error 2 is basically “Selected Disk does not exist“.

    Which likely means that grub is pointing to a disk or device that is either not recognized or as stated, doesn’t exist. It may be pointing to (hd0 0,1) instead of (hd0 0,0) or whichever missconfig. In my case with the newly installed RAID, it’s likely the issue of GRUB being non-existant on subsequent disks, or not mapped properly to the MD array.


    Is it even possible for a layman to fix things like this or should I just drop the whole freakin thing out the window and into the cold winter night?
    January 4, 2011 12:31:25 AM

    I just came over soemthing that might be of most importence here.
    The raid 0 I now have set up is a hardware raid 0, correct?

    Could it be that the raid was originally set up with software raid?

    Could that explain why I cant boot now?
    --------------------------------------------------------

    If that is the problem how can I once again use software raid?

    Is there any diagnostic tools that might be able to read data from drives to see if it was setup as software raid or hardware raid?

    I guess software raid could actually be the case. Cause I can wagely remember setting one partition for boot, one for cache and one for home. Maybe I did this in the software raid setup?
    January 4, 2011 12:32:42 AM

    Quote:
    Ok where's your ubuntu disk?



    Pretty sure I can find that one. It was setup almost two years ago.
    But maybe I can use any ubuntu disk?
    January 4, 2011 1:48:09 AM

    I have had my finger on every possible setting now I belive. So when I suddenly saw ubuntu splash screen and routine check of drives I can not be sure what caused the sudden changes. I did actually change two settings last time. I disbled all DMA. But also I disabled the raid in BIOS. Have not logged in yet still waiting for disk check. But it does seem to be ok now. I will start backup as soon as I am logged on.

    Still got some nails left, but most of my hair is now scattered around my desk and chair. Guess it is time to read up on raid and make a rational descicion on what raid to use, and also to choose between hw and sw raid.
    January 4, 2011 2:36:35 AM

    Yes changing to sw raid made it all work.
    I am doing backup now and will start learning more about redundancy and pros and cons of raid.
    !