Sign in with
Sign up | Sign in
Your question

5850 can't run TF2

Tags:
  • Radeon
  • Graphics
Last response: in Graphics & Displays
Share
November 1, 2009 8:06:49 AM

So I was thinking that a card like the 5850 would destroy TF2 but when I started it up all I got was this error message: "failed to create D3D device"

I'm running the latest drivers from the AMD website i.e. ATI Catalyst 9.10 Suite for Windows 7 64-bit. When I go into launch options and type -dxlevel 95 it runs it but it looks pretty average at best. And if I turn on any AA at all the fps are crippled, what the hell is going on here?! Is it the 64-bit drivers that are to blame?

Any help would be appreciated.

More about : 5850 run tf2

November 1, 2009 8:30:51 AM

Provide your configuration boy! :pfff: 

November 1, 2009 9:24:11 AM

Is that a directx9 game? Maybe you need directx9 runtime to run it? Like what Ape said, config!
Related resources
November 1, 2009 11:59:18 AM

Quote:
User error obviously, please rename post "I cant run TF2", whatever TF2 is anyways...


Honestly, how noob does one have to be to not know what TF2 is?

And yes, pretty much any card released in the last two tears should tear through TF2 maxed without the slightest hesitation. I'd try reinstalling the game. I reinstalled after Win7, and that correct my probs.
November 1, 2009 1:52:51 PM

TheGreatGrapeApe said:
Provide your configuration boy! :pfff: 


This what you mean by config? I'm new to all the tech stuff so, yeah...

CPU: Phenom II 955
Motherboard: Gigabyte 790FXT-UD5P
Ram: OCZ Platinum DDR3 1333MHz CL7 4GB
GFX: XFX 5850
PSU: Corsair HX750
OS: Windows 7 64-bit

I don't know how it could be user error, I just started the game and got the error message. I guess I'll try reinstall it then.
November 1, 2009 2:54:46 PM

For anyone still wondering ! Its TEAM FORTRESS 2 And it sucks meatballs!
November 1, 2009 6:42:43 PM

TF2 is one of the best mp games out there.
November 1, 2009 6:55:21 PM

I have a 5850 and it most definitely will play TF2 just fine. 1680 X 1050 with all settings maxed. Without vsync enabled, it's turning over 200 FPS. And yes, I'm using a 64 bit OS with the 64 bit drivers... so don't be pointing your finger at ATI/AMD... you got some other problem.

Do any other games give you problems?
November 1, 2009 6:57:16 PM

I can max TF2 at 1920x1080 easily with an HD 4890. I would try posting on the Steam support forums, they'd be better fit to troubleshoot it.
November 1, 2009 6:57:36 PM

UrbanToaster said:
This what you mean by config? I'm new to all the tech stuff so, yeah...

CPU: Phenom II 955
Motherboard: Gigabyte 790FXT-UD5P
Ram: OCZ Platinum DDR3 1333MHz CL7 4GB
GFX: XFX 5850
PSU: Corsair HX750
OS: Windows 7 64-bit

I don't know how it could be user error, I just started the game and got the error message. I guess I'll try reinstall it then.



question.. did you get that hx750 from newegg? did you read my velvet bag review ^_^??
November 1, 2009 10:18:26 PM

try re installing, and if that doesnt work try to go into properties and one of the files in there should be verify integrity of game or something like that, click that and let it run
November 1, 2009 10:21:07 PM

eklipz330 said:
question.. did you get that hx750 from newegg? did you read my velvet bag review ^_^??


Oh my god I totally saw the velvet bag review! That was great!!!
November 2, 2009 6:25:16 PM

Ran that integrity thing and it found no faults.

About testing other games, I'm getting at maximum 0.5Mb/s so it takes a looong time, to download things. Haven't tried to reinstall yet but I will leave my computer on for about 2 days for TF2 to re-download at that speed.

I found that review as well...LOL
!