Cool'n'Quiet disabled but CPU still underclocked

Hello,
I have recently installed a new AMD Athlon II X4 620 processor, everything went well but once I had booted up, I opened up CPU-Z and it had listed my CPU as running at 803.7 MHz with a multiplier of x4.0.


I thought that this would be Cool'n'Quiet running, as I was doing nothing at all except CPU-Z, so I rebooted and went into the BIOS and found it was indeed enabled. I have now disabled it however it still runs at 800MHz. I went back to the BIOS and also disabled something along the lines of CPU Thermal Control, but still at 800MHz. I then tried overclocking slightly to force it to a higher speed, however using both the BIOS and AMD Overdrive, it just boosts it from 800 to 850 MHz. I have also tried manually selecting the multiplier.

Please has anyone got any ideas as to why it won't stick to it's stock speed?

Thank you for any help
Rob
3 answers Last reply
More about cool quiet disabled underclocked
  1. Did you update your motherboards BIOS? Does the board even have proper support for the 620? Those are common causes for AMD processors to run at 800mhz even when put under load.
  2. Check your system power options menu in the control panel if you feel your BIOS is current ---- Windows may have you in a green power mode even after you disable C&Q
  3. I was using a beta bios from Gigabyte, so I decided to try going back to a previous version, and voila! Everything is okay now. Thanks for your help!

    Rob
Ask a new question

Read More

CPUs BIOS