8940g problem

I got my 8940G this week 1/6/10. Used it 4 hrs 1st night to register, Microsoft updates, burn the 3 Recovery Discs. Used it 10 minutes 2nd am. It was plugged in all the time. When I tried to turn it on last pm (48 hrs from first turning it on) it wouldn't turn on at all. I did all the Acer FAQs things (press power button for 30 seconds -- with/without power cord attached, with/without battery, etc.), but it is dead. I used my multitester and noticed LED on power brick goes out whenever cord attached to 8940G. When power brick LED is on get 19.5 VDC, when LED on the brick is off get about 1 VDC. On the 8940G itself the front left LEDs worked when computer worked, but not now.

I have communicated with Acer on support website and telephone. They authorized sending it to Acer service center in Texas.

Anyone else with this problem?

Any help would be appreciated.

Thanks, David
5 answers Last reply
More about 8940g problem
  1. Send it in. Could be the power supply or motherboard.
  2. Took it to local retailer to try new power supply. The new one at store (universal, not Acer) has LED that began blinking when attached to the Aspire 8940G. So, not power transformer brick. Sending everything out Monday by Acer supplied FedEx shipping number (nice of Acer).
  3. Acer in Texas found multiple system failures, so they sent a replacement 8940G. I received it a little over 2 days ago. It works and it is a fantastic machine! Very fast and stable. Very happy!
  4. GEEZ! Didin't know what an Acer 8940G was. It's a netbook!

    Glad the issue was resolved.
  5. It is used about 6 hrs per week. The NEW 8940G hard drive is about to fail according to the SMART system. Going to do a complete backup tonight
Ask a new question

Read More

Power Supplies Power LED Monitor Components