Sign in with
Sign up | Sign in
Your question

System error after BIOS Update

Last response: in Motherboards
Share
April 19, 2010 7:55:05 PM

Hi guys. I'm using an ASUS M2N motherboard. I updated the BIOS with the ASUS Update utility. It told me to restart system so i confirmed. After restart just a black screen showed up, my monitor's power LED is blinking, but there is no message like 'No Signal' on the screen,and it just stays like that. What should i do now? Any help is appreciated.
a b Ĉ ASUS
a c 234 V Motherboard
April 20, 2010 1:45:27 AM

Flashing from a Windows utility too often leads to a corrupted BIOS. Clear the CMOS. If that doesn't help, you can use the CrashFree BIOS utility. Instructions should be in your manual.
April 20, 2010 2:36:35 AM

Crashfree BIOS utility didnt work since the PC didnt even boot up and stuck at black screen, like no signal from video card. Tried to clear CMOS by the jumpers and removing the battery, didnt work also. So i removed all cables all the cards from my mainboard, get the mainboard out of the case, put the all cards back in, started the system outside the case with a different PSU, it worked like charm after that. Had to do all these crazy things after trying to clear CMOS with all the ways i read on internet for an hour. Thanks for your help.
Related resources
April 20, 2010 2:37:53 AM

Well forgot to add, weird thing is when i check my BIOS version now , it shows the one that i was trying to update, the update was a fail, but dunno how come my BIOS version changed :) 
a b Ĉ ASUS
a c 234 V Motherboard
April 20, 2010 2:45:01 AM

When you cleared the BIOS, did you power off or disconnect the PSU? Glad to know that it works fine.
April 20, 2010 3:20:05 AM

Tried both ways, first just powered off from the rocker-style switch behind the case, then tried disconnectiong the power, none didnt work. Its weird. :) 
!