Sign in with
Sign up | Sign in
Your question
Closed

My wifi network card (dlink dwl-520+) doesn't work in windows 7

Last response: in Networking
Share
November 10, 2009 6:59:06 PM

as the title says. any fixes/drivers? im connected to my router with my ethernet cable.... would prefer to keep using my old card rather than get a new card, its suppose to work, why don't they support thier hardware once a new OS comes out, seems like such a waste to throw out a perfectly good wifi card.
November 11, 2009 12:38:38 AM

Have you tried looking for Vista drivers?
Score
0
November 11, 2009 12:39:22 AM

i did a search on the dlink website, nothing turned up
Score
0
Related resources
November 16, 2009 7:19:56 PM

try to explain it in englisch. try as follow.
go into hardwaremanager.
rightclick on your wlan adapter.
update driver,
look in your computer for driver,
search the list of driver in your computer
switch off "show only compateble hardware".

now you will get a whole list of hardware.

select atheros communications.

here you will find the 520+, because it has a atheros chip.

hope it works.
Score
0
November 16, 2009 7:59:51 PM

heniu said:
try to explain it in englisch. try as follow.
go into hardwaremanager.
rightclick on your wlan adapter.
update driver,
look in your computer for driver,
search the list of driver in your computer
switch off "show only compateble hardware".

now you will get a whole list of hardware.

select atheros communications.

here you will find the 520+, because it has a atheros chip.

hope it works.


i did what you said but now i have a new problem, it will not install, it says "the device cannot start. (code 10)"

Score
0
November 17, 2009 2:30:36 PM

Ok next try
Sorry, the G520+ does'nt have a atheros chip. it has a texas instrument chip.

I tried following.

downloaded all drivers for g520+ from dlink ftpsite ( dlink support and then to the ftp site.) dwl-g520+ archive

unzipped all files to separate folders.

delete all dlink software and clean the register from dlink and d-link data.

next step. dont install any utility software by set up. windows 7 has its own. you only need a driver.

... hardware manager- update driver.... folder x:\DWL-G520+Utility+driver and Go

its working now only with WEP. still working on WPA

Good Luck Heniu
Score
0
November 17, 2009 3:31:01 PM

More info to my last add.. Make a windows update after installing the driver. microsoft will give an update wich makes also WPA possible. in my system its working.. Yeeeh.

good Luck Heniu

problems. try skype: heniuffm ( invisible...just write or call)
Score
0
November 18, 2009 5:42:21 PM

still doesn't work, i am using windows 7 btw.

i can post screenshots later to show what i mean
Score
0
November 19, 2009 2:28:16 AM

In my system it is only working with the windows 7 32bit Version. still working on the 64 bit Version.
Maybe that is te Problem.

heniu
Score
0
November 19, 2009 2:50:56 AM

yes, i have the 64 bit version
Score
0
November 19, 2009 9:06:37 PM

has anyone tried this under windows xp mode, windows 7 seems to have this feature, i am not sure what it does yet, i will have to download windows xp mode from the MS site to make sure
Score
0
Anonymous
December 29, 2009 2:57:09 PM

I have the same problem, nobody find a solution to use the DWL-G520+ on windows 7 64-bit?
Score
0
February 28, 2010 11:29:57 PM

Im still having trouble finding G520+ drivers could you please send me to my email.
Email: ptpavankumar@hotmail.com


Thanks a million in advance.
Score
0
March 31, 2010 6:14:03 PM

O, please, send to me too:
k.malyshev@ovi.com
Its dont downloaded!(
Thanks a million in advance!
Score
0
Anonymous
April 5, 2010 6:29:48 AM

expxe said:
i downloaded the 307 driver from here, is it the right one? do you have a link, because the 307 driver won't install from device manager

ftp://ftp.dlink.com/Wireless/dwl520+/Driver/

thx



Hello expxe,

Thanks 4 ur guide, my probs also already solve..

Thanks u so much !!
Score
0
February 17, 2011 10:38:23 PM

i instal the driwers in windows 7 32 bit no problem. but it dont let me ti put in thr key for the router. it starts to toubel search. anny one whit the same problem?
Score
0
May 1, 2011 2:21:23 PM

sorry to unbury this topic, but i´ve done what it´s said but my computer only connect to WEP, and i need it to connect to a WPA.
i´ve tried to update trought a free conection and windows said that the installed drivers were the newest ones.can anyone help?
Score
0
December 2, 2011 7:00:05 PM

crassus96 said:
sorry to unbury this topic, but i´ve done what it´s said but my computer only connect to WEP, and i need it to connect to a WPA.
i´ve tried to update trought a free conection and windows said that the installed drivers were the newest ones.can anyone help?





Guys, I have been using the d-link DWL-520 (rev.E) wifi card since 2003 and am STILL using it in my windows 7 rig as we speak. How? I just use the original drivers that came with the CD. I lost the CD years ago, but saved the drivers on my HDD. For some reason windows always installed the wrong drivers and it didn't work when I installed the "updated" drivers, but the old ones do, weird. So all I do is go to device manager, and select driver... and open up the drivers folder I saved years ago. WOrks like a charm. If you guys need the the drivers leave your email.
Score
0
December 15, 2011 3:02:50 AM

hertswenip said:
Guys, I have been using the d-link DWL-520 (rev.E) wifi card since 2003 and am STILL using it in my windows 7 rig as we speak. How? I just use the original drivers that came with the CD. I lost the CD years ago, but saved the drivers on my HDD. For some reason windows always installed the wrong drivers and it didn't work when I installed the "updated" drivers, but the old ones do, weird. So all I do is go to device manager, and select driver... and open up the drivers folder I saved years ago. WOrks like a charm. If you guys need the the drivers leave your email.


I just happened upon this thread. I think I could use those drivers. I can't seem to get the ones I downloaded to recognize the car, but I know its working because I'm connected to my wifi on linux with the same card.

Could you send them to petekschmidt@gmail.com
Score
0
December 15, 2011 7:55:59 AM

Sent. BTW I've only been using 32 bit windows versions, I haven't tried it with 64 bit yet.
Score
0
December 15, 2011 7:58:35 AM

Methodminus said:
I just happened upon this thread. I think I could use those drivers. I can't seem to get the ones I downloaded to recognize the car, but I know its working because I'm connected to my wifi on linux with the same card.

Could you send them to petekschmidt@gmail.com



Can you double check the address? I just got a delivery failure notification
Score
0
December 18, 2011 4:29:59 PM

Sorry, I figured this forum would email me when this message was responded to.

My email is definitely petekschmidt@gmail.com

Maybe the attachment is too big or something...no idea. Could you try again?
Score
0
December 22, 2011 4:27:44 PM

Dutch version of D-Link's site has the drivers for Win7 (x86 & x64.) >

In google translate for non-dutch speakers...
Score
0
December 22, 2011 6:27:17 PM

This topic has been closed by Area51reopened
Score
0
!