Can't get past HD on CD install

I have a box with a Tyan motherboard that is driving me nuts. Trying to install Ubuntu from external USB CDRom. Can't even get to BIOS with a SATA HD in the box. Says "entering setup" but then displays name of HD and hangs. Remove HD, I can get into BIOS, where I disable all boot devices BUT CD. With no HD, I can boot from CD fine.


Reattach HD, power up, same problem... sees HD, stalls, won't go past displaying the name of the HD (whether or not I hit Del to access BIOS) despite the fact that HD is supposed to be disabled.

Tried this with two different 1TB HDs.
5 answers Last reply
More about past install
  1. Tried a BIOS update yet,

    and or HDD are bad, try a third.


    Whats the model of the board aswell, model of the drives

    More info the better
  2. do you have a sata1 motherboard and you are using sata 2 drives? try the jumper.
  3. Probably the hard drive is bad, but have you tried waiting a long time for the computer to respond say 15 minutes or more, or you could try fitting the hard drive to another computer and reparation and reformat it.
  4. Yeah thats a good idea, test the drive on an another system if possible
  5. hmmm.

    I don't think the drives are the problem.

    if behaving correctly MB should IGNORE these drives when they are disabled in boot. bios update might help

    but will be doing an install on another box tomorrow, will test drives
Ask a new question

Read More

Chipsets BIOS CD-Rom HD Motherboards