Sign in with
Sign up | Sign in
Your question

Windows 7 64 Bit Only 4GB Useable

Last response: in Memory
Share
April 22, 2010 8:30:27 AM

I just reformatted my hard drive and reinstalled my 64 bit Windows 7. I was just in my task manager and noticed that my computer was only using 4 GB of memory. So i opened my computer properties and saw that my computer is in fact only using 4 GB of my 6 GB of installed RAM. Can anyone help me find out what is causing this problem so I can get the full use of my RAM please?

System Specs:

Mobo: Gigabyte X58A-UD7
Processor: Intel Core i7 920 overclocked to 3.2 GHz
RAM: 6GB(3x2GB) Corsair XMS3
OS: Windows 7 64-bit

Not sure if you need any of the other specs to fix this problem. If anything else is needed please let me know so I can provide more info.

Here's a link to a picture of my computer properties that shows Windows 7 64 bit only using 4GB of my RAM
http://s211.photobucket.com/albums/bb240/sabakunotaira/...

More about : windows bit 4gb useable

a b } Memory
April 22, 2010 8:46:46 AM

What version of windows 7 do you have? (Basic,Home premium,Professional,ultimate)?
m
0
l
a b } Memory
April 22, 2010 10:30:30 AM

When a whole stick of memory appears not to be usable, that can often be caused by poor pin contact between the socket and the CPU. It's been fairly common on 1156s CPUs recently and has also shown up in these forums on 1366 CPUs. Sometimes reseating the CPU is enough to solve the problem. Other times there is a bent pin or two that need straightened out. If you take the CPU out to reseat it, may as well look for bent pins while you're in there.

For some more details and a link to an Intel guide, check out Bilbat's Gigabyte sticky and search for the phrase: i3/i5/i7 'Missing' Memory
http://www.tomshardware.com/forum/272698-30-gigabyte-gu...
m
0
l
Related resources
April 22, 2010 11:30:20 AM

Hmmm, that is strange. It's not an issue of which version of Win7 you are running as it is only Starter x64 that has a limit below your installed RAM, and that limit is 2GB.

It's not that a memory stick is not being registered as from your photo it shows that the system recognizes that 6GB is installed, just that it's only allowing 4GB to be used.

I know that in many systems BIOS, there is an option called "OS Install mode" which is there to limit the amount of system RAM to a lower amount to prevent errors during OS installation (some OSs can't install when there is "too much RAM" present, for example Vista would BSOD until certain updates were installed if there was RAM over a certain amount). But I can't recall if the OS would see that the extra RAM was there and just not used it, or was it totally hidden from the OS until the mode was turned back off in BIOS.

Other info that could play into this is what video card(s) do you have? They can be creating a memory hole that is eating into the usable as well as other dynamic mappings.
m
0
l
April 22, 2010 5:31:15 PM

I'll have to check my CPU socket for bent pins or just reseat my CPU. Thanks for that info. However, I am very low or out of thermal paste so I would like to try other options before I go for that.

I'll check my BIOS for the OS Install Mode after I post this and see if that can fix it.

Also, if it actually helps, my video card is a radeon 5850 and my Win7 version is Professional.
m
0
l
April 24, 2010 7:11:12 PM

the grapics card will use your ddr(1-2-3) for extra graphic buffering
m
0
l
June 19, 2010 8:08:56 PM

Run MSCONFIG

Check to see if selective start is selected.

If yes, go to the boot tab.

Click "Advanced Options".

Deselect the maximum memory option if it is selected.

Also, you can optionally select the number of processors to increase the boot speed.

Click on apply to apply the new settings.

Reboot the computer. Once the computer is rebooted, right click on "Computer" on your desktop and select properties. Installed memory should now show just the memory installed rather than the 2 components (installed and usable).

Hope that helps

Bob
m
0
l
September 8, 2011 8:29:51 AM

This worked for me... Thanks alot....
RJMc said:
Run MSCONFIG

Check to see if selective start is selected.

If yes, go to the boot tab.

Click "Advanced Options".

Deselect the maximum memory option if it is selected.

Also, you can optionally select the number of processors to increase the boot speed.

Click on apply to apply the new settings.

Reboot the computer. Once the computer is rebooted, right click on "Computer" on your desktop and select properties. Installed memory should now show just the memory installed rather than the 2 components (installed and usable).

Hope that helps

Bob

m
0
l
June 11, 2012 10:10:55 AM

PC see the RAM, WIN 7 couldn't see and use it ! May be dual channel or single channel mixed up in WIN 7, stupid bug of MS.

My case solved:
Fujitsu LH520
Installed RAM:
KINGMAX DDR3-1066 2GB
SAMSUNG DDR3-1066 2GB
=> BIOS see them, Windows see them
=> Dual channel, with CPU-Z
=> installed 4GB, 2050MB hardware reserved

Installed RAM:
SAMSUNG DDR3-1066 2GB
=> installed 2GB, 2MB hardware reserved

Installed RAM:
KINGMAX DDR3-1066 2GB
=> CANNOT BOOT !!!

Installed RAM:
SAMSUNG DDR3-1333 2GB
=> installed 2GB, 2MB hardware reserved

Installed RAM:
SAMSUNG DDR3-1333 2GB
SAMSUNG DDR3-1066 2GB
=> installed 4GB, 2MB hardware reserved
Available: 2975MB
Cached: 1298MB
Total: 4094MB
Installed: 4096MB

Installed system: Windows 7 SP1 64-bit
In msconfig, normal boot selected.
In boot, advanced option, max. memory unchecked.
No memory remapping or frame buffer options in BIOS settings.

Conclusion:
In-compatible memory WITH WINDOWS 7 ONLY !!!
or dead memory of the KINGMAX D3-1333 !!!

m
0
l
June 17, 2012 10:51:22 AM

im using hp pavilion g6 laptop having 4gb Ram but it only show as

Installed Physical Memory (RAM) 4.00 GB
Total Physical Memory 2.45 GB
Available Physical Memory 1.36 GB

Im using window 7 ultimate-32bit operating system
in System property it shows
Installed Physical Memory (RAM) 4.00 GB(2.45Gb)usable
m
0
l
a c 347 } Memory
a b $ Windows 7
June 17, 2012 1:41:18 PM

This is OLD Thread - Please start a New Thread.

Thanks.
m
0
l
July 9, 2012 3:58:15 AM

Yours is 32-bit win7 problem, addressing only 3.2GB, the display use some of your main memory.
Solution:
- use win7 64-bit, working fine with 32-bit browsers, java, applications ...
- use resmon.exe to check
m
0
l
!