Sign in with
Sign up | Sign in
Your question

Sound quality with windows 7

Last response: in Systems
Share
October 28, 2009 6:28:29 PM

Hello all, first time poster here at Tom's. Nice to be a part of the community. Anyways, to the problem...

I built my system about a year ago, with windows xp. Everything was fine, after a while I got the Creative Sound Blaster x-fi xtremegamer sound card. Again everything was fine (after installing drivers). Well I recently did a reformat and installed windows 7. Installed all of my games, programs and drivers. All was well I thought. I proceeded to log on to World of Warcraft and joined a battle ground, where multipule people are in a very close vacinity so a cluster of sounds usually come flying out of the speakers due to the many spells being casted. The sound becomes very bad, hard to explain the sound exactly just seems poor quality, a bit crackly, i would explain the sound as being crunchy. Not crisp and clear. Would anyone have any light to shed on this problem?

Thank you for your time.

Strider

More about : sound quality windows

October 28, 2009 9:56:46 PM

i DO have intergrated sound... I will try to disable that when i get home. Thank you very much, and i will update this thread asap when i find out.
m
0
l
Related resources
October 29, 2009 1:45:40 AM

Well i disabled the realtek onboard sound... still low quality. I was told by someone else to whipe ALL audio drivers and re download just the one i need again. how do i find and delete all audio drivers and do u recomend that
m
0
l
a b $ Windows 7
October 29, 2009 8:52:20 AM

How did you first install the sound driver, did Windows 7 automatically recognised the card and installed the drivers or you download it from Creative?

.................................................................................................

1.Use Driver Sweeper and remove the Creative sound drivers.
http://downloads.guru3d.com/Guru3D---Driver-Sweeper-%28...


2.From the following link, choose windows 7 version , download and install driver;-
http://support.creative.com/downloads/welcome.aspx?nLan...



Also it might help if you try use the card in different pci slot. (remember to discharge yourself from static by touching the metal casing, before you swap it in different slot)

....................................................................................................
Onboard sound must be disabled else it will conflict with the creative sound card
m
0
l
October 29, 2009 3:21:00 PM

Do you have a nice video card?
Did you get a new one recently?
I have worked on computer that had interference from the video card.
My suggestion would be the same as ibnsina.
Try a different PCI port. (further away from the video card if possible)
m
0
l
!