Sign in with
Sign up | Sign in
Your question

Windows 7 will not see 16GB of RAM, why?

Last response: in Memory
Share
April 25, 2010 3:50:41 AM

Hello,
Here is my story:
I recently purchased Micro-Soft MS WINDOWS 7 Ultimate 64 bit. I previously purchased Micro-Soft (MS) VISTA Ultimate 64 bit last year. When I got enough spare change to upgrade my 4 bit RAM system to a 16 giga Byte system, I did. I upgraded to the 16 giga bytes (GB). The MS VISTA Ultimate (MSVU) did not see the 16GB. I could not send it back. I knew I would not get my money back, as I understand the rules. (MSVU) is supposed to see up to 128 GB of RAM. It never worked at 16GB. The system world lock near the end of loading. It was recommended that I transfer to MS WINDOWS 7 by several vendors. MSW7 never worked either. Neither OS could see past 8GB. I sent the motherboard back to the manufacturer to be tested and replaced, and the RAM back to be replaced and tested. The OSes still gave the same out come, limit 8GB of RAM.


My question is WHY? The BIOS see 16GB. LINUX sees 16GB. Whats wrong with MS Vista Ultimate and Windows 7 Ultimate for the 64 bit platforms?

Thank you.
Broke and disappointed for the moment. BDM.

http://img.tomshardware.com/forum/uk/icones/smilies/hel...

More about : windows 16gb ram

a b } Memory
a b $ Windows 7
April 25, 2010 3:56:51 AM

Really amazing. You never mentioned a single system spec., much less which motherboard you are referring to.
m
0
l
April 25, 2010 2:04:35 PM

Here are the relevant/basic specifications of my system:
1). My Motherboard is a: Gigabyte (GA-MA790-DS4 F5) which was replaced and tested, then sent back to me by Gigabyte.
2). The RAM as mentioned previously is: 16 gigabytes of (4gig sticks for 4 slots): 800Mhz, PC6400 DDR SDRAM which were replaced and
tested at MEMORY AMERICA.
3). My BIOS is by AWARD Modular; BIOS v6.00PG.
4). My CPU is an: AMD Athelon (tm) 64 x 2 Dual core (Phenom) processor at 2.4 MHz. Will be upgrading to Phenom II 3.0Mhz.
5). 2 HDD rated at 2Terabytes by Hitachi.
6). Video card is G-Force 9400GT for the moment.

Thank you in advance for any help in this matter.
m
0
l
Related resources
a c 128 } Memory
April 25, 2010 6:04:02 PM

Have you tried cpu-z? Have you checked Gigabyte's website for a bios update? Before updating the bios, check the ram settings, including a "memory mapping" setting in the bios. Your board may not have this setting, but check anyway. If your ram is a decent brand (crucial, corsair, kingston, samsung, pny, pqi, micron) you probably have a motherboard issue.
m
0
l
April 25, 2010 7:47:21 PM



Is this your motherboard?

If so, are you using memory from the support list?

m
0
l
April 25, 2010 7:57:29 PM

Send a message to Gigabyte to see if your board actually supports 16GB or not. The memory support list for your board doesn't include any 4GB modules. The largest modules listed are 2GB sticks.
m
0
l
May 6, 2010 12:07:14 AM

Hello again.
I hope you keep this solution up a while, with the question.

The "Read First" thread by (Bilbat---[The Doc]) was a little over-kill for me. However, I read it all. Next I continued working with the vendors of the memory and the Gigabyte! I love those guys. Eddy of Gigabyte technical support team USA really solved the problem. Part of the solution was mentioned in the "Read First" on your website. Secondly, I must say "I Love LINUX Red Hat". It could see the 16 gig all along.

Recall:" My Motherboard is a: Gigabyte (GA-MA790-DS4 F5) which was replaced and tested, then sent back to me by Gigabyte.
2). The RAM as mentioned previously is: 16 gigabytes of (4gig sticks for 4 slots): 800Mhz, PC6400 DDR SDRAM which were replaced and tested at MEMORY AMERICA. "

Everyone who sent in comments: Thank you. Andrew of Memory America, and Hector L of Mwave.com was very help in this trouble shooting. My Mobo uses DDR 2's and not the newer DDR 3's. I don't believe I stated that clearly.

Nevertheless, the answer to the problem is this: There are two possible answers.
1). The BIOS had to be updated.
2). The BIOS graphic card bus had to be changed.

1). The BIOS had to be updated. When I sent the board back, I thought Gigabyte would also check the BIOS. But, I should have been more specific. To update the BIOS was not as bad as I remember doing (the process) 5 years ago or so. The "Read First" thread reminded me that I did not want to touch the BIOS update again. But as a last result I knew I would.

Bilbat's thread (Great stuff too) say's:"My advice to most is to consider your experience level - if the idea of flashing firmware gives you cold sweats, and the heebie-jeebieshttp://img401.imageshack.us/img401/7303/0174a.jpgdon't do it, unless you know you have a problem that you know is addressed in a later GB release - and, DON'T use @BIOS! Also, don't erase a BIOS file itself - you never know if it'll be around to be found later, should you discover the flash wasn't all that great... If flashing is no big deal to you, and you're confident in your procedure, go ahead - if it's a 'dud', you can always 'flash back' to the last thing that worked well for you. Do get in the habit of backing up your CMOS parameters to removable media (see BIOS - Saving CMOS below) - it makes the whole flash & set-up process so much easier, and GB/Award hardly ever (I won't say 'never', but it's very rarely a problem) 'break' a BIOS so that CMOS tables saved in the last release won't load into the latest release... "

Now you don't have too. It is "plug and play" almost fully automated now. "CAKE"! Thank you Gigabyte. But backup the automation tool or Wizard. It took all of 5 minutes, from the website and downloading, to uploading the updated BIOS. Eddy of Gigabtye was "On Point". I was running version F5 or Version 6. I'm now running version 9 point something.

2). The BIOS graphic card bus setting had to be changed. I have a EVGA 9400 GT video card installed in a PCI slot.
I believe there are two choices:
A). PCI or
B). PEG (PCI Enhanced Graphics)

Okay. The basic steps from the BIOS is:
a). Turn <OFF> the computer. b). Use an ESD strap for grounding yourself. c). Install the 16gig into the system.
d). Turn <ON> the system. e). Press and hold down the <DELETE> button for 10 seconds or until the BIOS comes up (Over kill).

f). When the BIOS loads up, Press the function key <F6> which is the "Load Fail-Safe Default", as mentioned in the "Read
First" (RF) thread.
g). Press the <F7> key, which is the "Load Optimized Default". I had performed this function numerous times, but it was
cool to have the Gigabyte tech say do this, without reading this site. He was "On Point".

Recall: Bilbat RF:"The BIOS' "Load" functions (Load optimized/load fail-safe) similarly do 'discovery', but they do a much more thorough job of it, querying every piece of hardware, and then 'setting' the dozens of parameters you will find in your BIOS set to 'auto'; until this is done, your board is pretty much 'brain-dead', and can not be expected to work correctly, if at all. Think of it this way: if you woke up one morning, and not only couldn't remember 'who you were', but also couldn't remember which finger was on which hand - you'd be in a world of hurt![:lectrocrew:7] "


i). Anyway, press the <F10> key. The system will reboot.
j). Press the function key <F9>. You should see your 16GB on the "Install Memory" line. Press the Esc key.
k). Go to the ADVANCED BIOS Feature on the main menu. At the bottom of the listing go to: Init Display First:
l). Change the PCI to [PEG].
m). Press F10.

Now when the system reboots, let it go all the way. It should not lockup, if your system is similar to mine.
The system works in MS Vista Ultimate now. I know it will work on MS Windows 7 Ultimate. MS is still the king on the OSes. And Thank you Tom's Hardware group (my fellow Geeks: the engineers, technicians, physicists, and chemists), you make this site interesting. Bilbat, keep up the good work. One out of two ain't bad. Ain't bad at 'tall. Smile : )


>"The memory support list for your board doesn't include any 4GB modules. The largest modules listed are 2GB sticks."
Not True. Better luck next time.


Now this problem is SOLVE!
m
0
l
May 6, 2010 1:30:08 AM

the board only supports 8 gig
m
0
l
May 6, 2010 9:12:25 AM

However, I'm talking about my mobo: GA-MA790-DS4 F5. It supports 16 gig.
The Sea. :o 
m
0
l
!