WAP to WIreless Router problems

I have a Linksys WRT54G and a WAP54G that I am tryingto get to work with each other. I have been running the WRT54G for some time with no problems other than some dead zones in my house. It is this reason that I have added the WAP.

I added the WAP, assigned it the same SSID, and security key. My Router is at 192.168.1.1 and I assigned the WAP 192.168.1.2. I can connect wirelessly to the WAP, but I can not get past it. At first, I could not even ping the Router until I noticed that it had NAT running. WHen I turned that off, I was able to ping the Wireless Router, but I still could not get past it.

I know the two units can see each other (I had allowed the WAP to get a IP address through DHCP to verify they were both on the wired network, and they were) but for whatever reason, if I go wireless through the WAP, I can not hit the internet. WHat may I be missing in my setup?

Yes, the WAP is on a hard wire cat5 network. Yes, both have the same SSID, but are on two different channels (this is how I can verify if I am on the WAP or the Wireless Router).
6 answers Last reply
More about wireless router problems
  1. It's not clear to me, is the WAP54G connected to the WRT54G via wire or wireless? I initially thought it was wireless, but then you mentioned the hard wire in the last paragraph and it threw me off.

    The WAP54G supports several modes, including AP, AP Client, and Repeater. If the WAP54G is connected to the WRT54G over wireless, then you need Repeater mode. Is this what you've chosen in the configuration?
  2. The WAP is connected via a wire. Wireless was too flaky at the far end of the house and I have a hub there so I am hard wiring it.

    I have chosen the default AP mode (not AP client).
  3. So it sounds like the wireless clients *are* connected to the WAP, but it's just an Internet access issue. You mentioned turning NAT off on the router, but that doesn’t make sense. Without NAT, those clients cannot share the Internet. That’s the whole point of NAT. Without it, each client would need their own public IP address, and I’m sure that your ISP is only providing access to ONE public IP.

    What does IPCONFIG /ALL show for those wireless clients? It should report the IP address assigned, the default gateway (the router's IP address), the DNS server(s), etc.
  4. I don't have the equipment in front of me now, so I will comment about the IPCONFIG item later.

    Let's do this. How should the WRT54G and the WAP54G be configured? I basically just plugged the WAP in last night, assigned an IP address, and told it the gateway IP (the routers IP address...correct?). I gave it the SSID, and encryption key, and I would think it would be good to go. Is there something I forgot?
  5. perrybucsdad said:
    I don't have the equipment in front of me now, so I will comment about the IPCONFIG item later.

    Let's do this. How should the WRT54G and the WAP54G be configured? I basically just plugged the WAP in last night, assigned an IP address, and told it the gateway IP (the routers IP address...correct?). I gave it the SSID, and encryption key, and I would think it would be good to go. Is there something I forgot?


    That's basically it. It's actually a pretty simple setup as these things go. The WAP has to be plugged into a LAN port on the router. You assign it an IP/mask in the same subnet as the router (and obviously not already in use by another device, either statically or via DHCP). Technically you don't even need to do that, or even assign the gateway IP! The assigning of those parameters is more about the ability to access the WAP from the router's subnet for administrative purposes, it’s irrelevant wrt the wireless clients. The WAP’s wireless clients are (should be anyway) using the DHCP server from the router for that information. That's why I checked to see if this WAP might come w/ a DHCP of its own, but I didn't see one, at least it wasn't mentioned in the manual (if it did, you'd need to disable it so it didn't conflict w/ the router's DHCP server). Finally, you just setup your wireless.

    So something else is amiss here. If I was looking at the screens, I’d probably notice immediately. Maybe something that’s not coming to mind at the moment. But as I said, it’s really a very simple setup in most cases. If setup properly, wireless clients on the WAP are just feed through, transparently.

    Try this. Reset the WAP to factory defaults, patch it to the router, and just connect to the WAP using the defaults. Assuming AP mode is the default (manual claims it is), it should work. You may have inadvertently changed something that’s causing the problem.

    Heck, try a different Ethernet cable, maybe the one you have is bad. Or maybe the router’s LAN port is flakey, try several. Try changing things up a bit in case it is a hardware issue.
  6. That was my next thought. Just plug it right into the router (same room etc) and all, but I would think I would need a different SSID so I can tell which box I am getting wirelessly. I'll give that a try tonight and see.
Ask a new question

Read More

Configuration Wireless Router Wireless Access Wireless Networking