Problem: Small squares on screen in some games.

Hallo everyone,

I have recently bought a new system. But I have some problems in games. I wanted to ask you the possible reasons for one of them.
My sistem is:
-Gigabyte P55-ud3r (all drivers up to date. I am waiting for new BIOS to finish its beta status. Then I will update my bios as well)
-Kingston 4gb (2*2) DDR3 1333mhz cl7
-500gb Seagate HDD 7200rpm
-FSP Epsilon 700W
-Intel i5 750
and ATI HD5850

I am using Vista home premium 32bit.

no overclock on anything.
no overheating on anything ( according to HD monitor and CCC results)

I used catalyst 9.10 for a while. After some problems which I guess related to the display drivers (mouse image getting bigger ect.) I changed the drivers to the catalyst 9.11 beta yesterday. I am not sure about the other issues. But one thing is still here.

I uploaded some screenshots because it is hard to explain. You can see the problem easily.

As you can see black boxes on the screen in Crysis are very disturbing. The funny thing is that there wasn't this issue before I reached that village after 15min. of gameplay. Then I stated a new game. Everything is perfect again. Then the problems started again when I reacht the village.

On the second screen you can see the squares but they are green now, after a small explosion. But there are black ones on the rifle.

Last screen is from Fallout 3. I experience crashes regularly on that game but it wasn't very good on my previous system as well so it is not the issue. On image you can see the green squares on the smoke/dust effect. I can also see some of them only on clouds sometimes. But they are very slight. You can realize that the squares are only in one area. The rest of the screen is ok.

I also tried Gears of War and Call of Duty 4 but I didn't see anything unusual on both games. I played each of them with full detail for 4 hours. Everything is ok.

The question is what is my problem here? Is it a driver issue or hardware issue? Have any of you guys experienced the same problem?

Thank you very much.
6 answers Last reply
More about problem small squares screen games
  1. This could be a driver issue so redownload and reinstall, also check for patches, the 5xxx series is still very new, so a few driver problems might be expected.
    Also check DX is fully up to date, it does not update automatically with Windows.
  2. Thank you for your answer.
    I uninstalled, driver sweeped and reinstalled my previous update last week. But nothing changed. I installed current one yesterday.

    I must be honest with you. I was totally unaware of the DX update thing. I installed my vista last week with my new system and updated. But I didn't install any DX10. And I guess none of the games I installed didn't too.

    Where can I learn my current DX10 version?
  3. Well, I updated the directx anyway. But still nothing has changed.

    Does anyone else have an idea?
  4. Here is the fix:

    My System Specs:

    AMD Phenom II Quad Core 3.0GHz
    4 GB Corsair RAM
    Windows 7

    I have had the same type of issues where I get random black squares (about 1/4 inch by 1/4 inch) that cover all over the screen when I am playing games like Crysis, Crysis Warhead, Mass Effect, and Mass Effect 2. I think that the problem is that Windows 7 has a difficult time using the DirectX 11 for games (and in my case, some games with DX10). In order for me to play any of my games, I have to make them so that they run with DX9 - which is a bummer because I bought that video card because I was excited to run games that utilized DX11. It also may just be an issue with Windows 7 and my particular video card. I also have the black square problem when I enable "Desktop Composition" in Windows 7. If I do not disable desktop composition, I get blinking square artifacts all over my screen (particularly when I move a window). I have not found a fix for this, but I have a feeling that if I was able to force Windows 7 to default to DX9 and not the current version it is running on, I could have desktop composition.

    Anyway...(the fix)

    To run some games in DX9, click Start, All Programs, Games

    Once you are in this folder, right click the game you want to run and select PlayDX9 from the drop down

    This fix worked for Crysis, but it did not work for Crysis Warhead because that option is not available. In order to run Crysis Warhead in DX9, type the following into the "Run" box:

    C:\Program Files (x86)\Steam\steamapps\common\crysis warhead\Bin32\crysis.exe -dx9

    There needs to be a (space) after the .exe, and then a dash and dx9
    (hence the \crysis.exe -dx9)

    Your program may not be located at the same place as mine (in the Steam folder), so you will have to find the containing folder, and modify the address.
    ex: C:\Program Files (x86)\Electronic Arts\ (and wherever else it may be)

    All I do is save the "run address" in a text document and copy and paste it in the run box whenever I want to play.

    I think that this fix will work across other games too, because by adding " -dx9" to the run command, you are telling the computer to run with that type of DirectX.

    Hope this helps,
  5. I'm pretty sure this a defect card. I'd RMA it rather than living with it. Both of you.
  6. This topic has been closed by Mousemonkey
Ask a new question

Read More

Radeon Games Graphics