Sign in with
Sign up | Sign in
Your question

I can only use 800mhz of my Pentium M 1 73GHz cpu

Last response: in CPUs
Share
January 16, 2010 8:41:03 PM

Hi, after a clean install with all updated drivers installed in the correct order, my cpu is stuck running at 220MHz when it's supposed to be 1.73GHz. I understand that the processor has speedstep, but the cpu never jumps pass 220 unless I change the settings in Network Hardware Control. Even then It only jumps to 440MHz. The BIOS shows Minimum CPU Speed to be 800MHz, Max 800MHz, and Capacity the correct 1.73GHz. I've played with quickset, everything. No viruses either. This seems to be a common problem with Dell Latitude Laptops, but I can't find a solution anywhere. Please help me out! PC is a Dell Latitude D810 that's supposed to be running a Pentium M 1.73GHz processor. THanks in advance!

*EDIT*Updated BIOS still no controls besides disable speedstep (which sticks cpu at 220MHz)...Ran Prime 95, RMClock, and CPU-Z all took me to the same 220 and 440MHz....Then, Tried taking out battery read somewhere that there can be a conflict between this model Dell's battery and the motherboard. Restarted, and upon restarting CPU at 800MHz instead of the usual 220MHz, then went into powersettings and switched to Home/Office Desk and viola 1.73GHz...until I started it up this morning...Now it's back to 220 and 440Mhz w/ 13x Multiplier.
a c 159 à CPUs
January 16, 2010 8:52:28 PM

Use cpuid, a free download, to determine your actual cpu speed. You can disable speedstep in most board bios if desired. I use it cause it works. You can also check the cpu specs on Intel's website by doing a search with the cpu model number.
m
0
l
a b à CPUs
January 16, 2010 9:07:34 PM

There is a program called RMclock which lets you manually set the stepping on your processor. You could try that and see if it fixes your problem
m
0
l
Related resources
a c 141 à CPUs
January 16, 2010 9:15:40 PM

Speedstep does not force your prcessor to go that slow; it does appear to be a bug. You don't say which OS you are running but if it is XP did you get the speedstep driver from Dell? Try changing your powerscheme to Home/Office which disables Speedstep in XP. I dubt it will do anything in your case but why not try.
m
0
l
a b à CPUs
January 16, 2010 9:43:22 PM

popatim said:
Speedstep does not force your prcessor to go that slow; it does appear to be a bug. You don't say which OS you are running but if it is XP did you get the speedstep driver from Dell? Try changing your powerscheme to Home/Office which disables Speedstep in XP. I dubt it will do anything in your case but why not try.


actually, speed step will go that far down. I have laptop that will go that low and it's able to go lower on some cpu's


As o1die said, it probably speed step. One way to make sure your cpu is running normally is to download prime 95 and cpu-z.

Cpu-z will be used for monitoring the cpu speed in real time.

Prime 95 is a stress program design to make an cpu to run at full speed and higher (if you have turbo boost)


Just run prime 95 in small FTT (or something close to it) under toucher test. See if the speed increase with prime 95 running.
m
0
l
January 17, 2010 12:12:18 AM

Clean the dust and see if it still happens
m
0
l
a c 133 à CPUs
January 17, 2010 12:55:21 AM

i had the same problem with a toshiba laptop in windows 7 would only run 800 mhz with speedstep off went to xp and it worked fine some mobile cpu and motherboards dont work well with windows 7
m
0
l
a b à CPUs
January 17, 2010 9:38:07 AM

Are you running the balanced or High Performance power plan? Power save mode may prevent the CPU from running at full speed.
m
0
l
a b à CPUs
January 17, 2010 12:47:57 PM

never hurts to update your bios.
m
0
l
!