Sign in with
Sign up | Sign in
Your question

Cant find ethernet controller

Last response: in Motherboards
Share
April 28, 2010 12:20:09 AM

Hello, tonight i reformatted as i do every couple of months but this is just my second time to reformat with a new motherboard i got 2 months ago. The first time i reformatted everything went perfect - no problems.

Tonight though when i installed everything i was unable to connect to the internet. A message pops uo saying "installer cant find atheros ar8121/ar8113/ar8114 ethernet controller on your system" then exits. I tried downloading the ethernet controller itself from the net but i still get the same error, no matter what i do.

My ethernet adapter/cable does not show up in device manager either so i cant actually disable it or delete it. I tried reformatting again and i still have the same problem. I was wondering is there anyone that can help me please as i dont no what else to do. Ive also checked the bios and both wlan and ethernet are enabled. Would a ethernet card fix this or..?

Thank you

the mobo im using is a P5Q PRO Turbo by the way, thanks for any help
a b V Motherboard
April 28, 2010 12:42:31 AM

Have you installed the motherboards chipset drivers? I think your problem is due to you not installing all of the required drivers. I am puzzled by you saying that the Wlan was enabled in the BIOS.
If you are sure that you have installed all of the required software correctly then another thing to try is to clear the CMOS RAM. If you still can’t get it to work after another reinstallation of Windows then a network card would be an easy and cheap solution.
May 6, 2010 11:05:04 AM

I am having the same type of issues with the same M/B and same Lan controller on a 9 month old PC. I have done all of the above including complete C:/ re-format & system re-install. When I did the re-install there was no sign of the Lan Controller in the Device manager nor could I force or find it by using the Install Hardware process. Once I installed a previous saved Image I could once again force it to appear using the Install Hardware process. I have tried the Original driver (from install CD), the update Driver from Asus site and the latest driver from the Atheros site. I have also tried 3 different BIOS versions to date with no success. All I get from Device Properties "is Cannot start device (error 10)". The Asus Support site has no revelations about this issue but does have a reference to CMOS Ram which I dont understand. What is being referred to by CMOS RAM. BIOS???

Mike
Related resources
September 7, 2010 3:48:55 AM

I too have the same problem ...
whenever im installing the lan driver it shows me a msg "Ethernet controller AR8121/AR8113 can't find in your system" then exits....

plzzz help me i'm using P5KPL-CM mobo.......





gurukiran
!