Sign in with
Sign up | Sign in
Your question
Closed

ASUS Xonar D2 - "Please plug-in audio device"

Last response: in Components
Share
January 17, 2010 11:30:49 AM

Hi!

I bought a few months ago the new high-quality sound card ASUS Xonar D2. I used it with Windows 7 (64-bit) a few weeks, until I changed a new 1TB HDD.

After that, I have done fresh Windows 7 installment about three times. I put it in the PCI-slot (tried both), fresh Windows 7 installment and the newest drivers (http://asus.com/product.aspx?P_ID=QsEKBPr6ko9pFF2D&temp...), but it gives a following message when trying to install the drivers:

"Please plug-in ASUS Xonar D2 Audio device"

So it won't recognize it any more, how's that possible? Is it in the 64-bit Windows 7 Ultimate, or what? Please help me, it cost me quite a lot :/ ...


PC's specs:

Cosair TX850w
MSI P55-GD65
Inte Core i5
4GB DDR3 OCZ Platinum
Club3D Radeon HD 4890


Thanks a lot!

January 21, 2010 9:56:54 PM

Wow. No wonder nobody here knew. Thanks for the update. It'll help me think twice about buying Asus, anyhow.
Score
0
Related resources
a b Ĉ ASUS
a b $ Windows 7
January 22, 2010 9:56:34 AM

Good to know.
I have never heard of that issue before, must be pretty rare.
Score
0
a b Ĉ ASUS
a b $ Windows 7
January 22, 2010 10:59:16 AM

...must be really rare.

Seriously, how could a cards EEPROM get overritten during a Windows install anyway? Can ASUS even be blamed for that? [Hows it their fault?]. I would also expect this to effect other C-Media chipsets (IE: HT Omega, Razer, etc)

Should also point out I've personally done two Windows installs on my machine (with an affected 790i motherboard) with an ASUS D2 plugged in, so I'm guessing its something REALLY low level, maybe even a BIOS setting which is causing the overwriting of the cards EEPROM. This is actually very interesting, wish I had a broken card to play around with...
Score
0
January 22, 2010 2:40:25 PM

Yeah, rather interesting, I'd say!

There were many others, in different forums, having the same problem, too. So it seemed to be "quite usual"?
Score
0
a b Ĉ ASUS
a b $ Windows 7
January 22, 2010 3:40:05 PM

Don't think its the card though; I find it hard to believe anything could go wrong to the point of a components EEPROM getting corrupted...

Here we go:

Quote:

Devices on the PCI bus are supposed to have certain predefined registers that contain the vendor/product and subsystem vendor/product IDs.
The ID registers are read by the operating system when booting to determine which driver to attach to the device; the BIOS is not involved with this.

Most chips used on PCI(-E) cards allow to be connected to a small EEPROM that contains the subsystem IDs so that multiple card models based on the same chip can be differentiated. That EEPROM is read by the controller chip before any driver is loaded, so the driver usually does not need to care about the EEPROM (except if other configuration information is also stored in there).

In the case of the Xonar's chip (a CMI8788, relabeled as AV200), the only way the EEPROM could get overwritten is that the value 80h or C0h gets written to the port at offset 80h in the card's I/O port range. Reports indicate that his happens with (some?) Phoenix Award BIOSes when the computer is booted from a CD or DVD, regardless of what is on the CD, so it is the BIOS code that writes to the I/O port.

Now the BIOS wouldn't just write random values to random I/O ports, so this is apparently some other write that gets misdirected to the card. An obvious candidate is the POST code debug port at absolute address 80h (which happens to be the only port in the 00-FFh range whose accesses are forwarded to the PCI bus).
I guess that the following happens:

The card's I/O port range is enabled while its base address is set to zero;

when booting from CD, the BIOS writes POST code 80h to port address 80h,

the card interprets this as a EEPROM write command.

The error happens in step 1. where the I/O ports are enabled with a wrong base address.

I do not know if this is a BIOS bug (where the BIOS sets a wrong base address), or a hardware bug (where the CMI8788 decodes some I/O port writes even when the I/O port range is not enabled).


http://vip.asus.com/forum/view.aspx?board_id=21&id=2009...

Very very interesting...
Score
0
January 25, 2010 10:52:07 AM

OK, I'm starting to get really pissed with this Xonar D2, really!

Firstly, I restored the corrupted EEPROM and was able to install the Windows 7 x64 drivers. The drivers installed nicely, but the Xonar D2 Audio Center wouldn't start. OK, nice drivers - I installed the Vista x64 drivers and then I could start the Audio Center.

Used my PC with Vista drivers smoothly a few days, but what next: a little red cross on the tray "No speakers or headphones are plugged in". Checked the device manager: Xonar isn't recognized, AGAIN! AAAAAND EEPROM restoring boot from the CD...

Next, used one whole day: "No speakers or headphones are plugged in". Took my CD ready on the table, but after reboot, Xonar is recognized?


WTF?! I'm starting to get frustrated with this rumba - buggy shitti drivers and EEPROM failures/card not recognized now and then...



I think, I have to sell this card and settle with the good old MSI P55-GD65's ALC889 HD audio. At least it works!

Score
0
a b Ĉ ASUS
a b $ Windows 7
January 25, 2010 11:09:34 AM

I would recommend Contacting ASUS and RMAing your card....

Just be sure to leave out the part with you flashing the EEPROM when you talk to them, they would probably frown on that.
To be sure, it should be working just fine.
Both my Essence STX and DX have no issues with the official Windows 7 drivers.
Score
0
a b Ĉ ASUS
a b $ Windows 7
January 25, 2010 11:33:57 AM

AGain, my D2 works fine, even on an effected board...

If the EEPROM is still getting corrupted, then something is seriously screwed up with the MB in my opinion. Soundcards just don't overwrite their EEPROM on a whim...
Score
0
January 25, 2010 5:08:21 PM

OK, I MIGHT have overreacted..

I re-installed my x64 Windows 7 and the Xonar's Win 7 drivers installed nicely on the "fresh" Windows. Have made a few reboots and everything seems to be fine, so far...

I think it had some conflicts with the Realtek's drivers, because I couldn't unistall them...

Hopefully everything works now! :) 
Score
0
Anonymous
a b $ Windows 7
February 11, 2010 3:14:50 PM

Hello

when i install the restoree.exe by cdroom i have an error

"Searching for sound card with CMI8788chip...
error: no PCI card with CMI8788 chip found
A:\>_ "

Well... what i did wrong or what i have to do?

SoundCard: Asus XONAR D2/pm

thanks...
Score
0
a b Ĉ ASUS
a b $ Windows 7
February 11, 2010 4:00:30 PM

Try installing the Latest Drivers.
Make sure to select your OS at the top!
Score
0
February 11, 2010 7:18:11 PM

i was gonna buy that and i definitely have win 7 x64 thanx
that might come handy
Score
0
March 14, 2010 10:28:32 PM

find the exact driver for your windows and card (D,DX, D2 ect) , took agies to find the right one once up and running it is the best soundcard their is
Score
0
April 25, 2010 12:50:13 AM

Quote:
Hello

when i install the restoree.exe by cdroom i have an error

"Searching for sound card with CMI8788chip...
error: no PCI card with CMI8788 chip found
A:\>_ "

Well... what i did wrong or what i have to do?

SoundCard: Asus XONAR D2/pm

thanks...


I have this problem too I think it's because it isn't being detected properly. if you have a look in windows under device manager and the hardware IDs they show up as something not xonar d2 or maybe even a soundcard at all.

PCI\VEN_13F6&DEV_0788&SUBSYS_02691043&REV_00
PCI\VEN_13F6&DEV_0788&SUBSYS_02691043
PCI\VEN_13F6&DEV_0788&CC_040100
PCI\VEN_13F6&DEV_0788&CC_0401

I am pretty sure this is why when trying to flash it has that error. it's also probably why a normal install of the driver is failing too or if it does install it bsod's when it finishes.

this just happened to me after 2 separate raid controllers were installed and later removed from my pc. it was working fine with the first raid controller in the pc and worked fine when removed. after the second raid controller was removed though the xonar d2 suddenly had no sound at all. so I rebooted and the xonar d2 card suddenly was showing up as not being installed and as a multimedia audio controller needing a driver to be installed in device manager as if it was the first time it had been installed. then I have the above problem.
Score
0
May 15, 2010 11:15:06 AM

the cd for this card comes with drivers for xp and vista if windows 7 goto asus.com for the correct driver and delete all previous ones , the card works great.had the same problem I never altered anything special in the registry ect I hope this helps you if still no joy contact asus
Score
0
May 19, 2010 11:09:08 PM

Thanks for all the info guys. I started having the problems above with my D2X after updating the firmware. Just about when I'm get ready to RMA the card I get it working again, usually after an hour or two. Just did a new build a couple of weeks ago and had to go through the same drama, everything works fine right up to the time it's removed from the computer. I'm not sure when I'll do it but I definitely plan to RMA the card before the warranty is up and no more firmware updates.
Score
0
!