Sign in with
Sign up | Sign in
Your question

Windows 7 Not booting after memory upgrade...

Last response: in Motherboards
Share
April 29, 2010 11:54:12 PM

Hello Forum,

first, here are my computer specs

CPU: Core 2 Duo E6700 running at 2.67Ghz
Motherboard: Asus P5N32-SLI SE Deluxe
Memory: Corsair XMS2 800MHZ 2Gig
Graphics: 2x XFX GeForce 9800GTX

Using windows 7 64 bits Professionnal edition

I decided today to go buy 4 gig of ram (2x gig) to replace my corsair and went with some Crucial Ballistix 4gig at 800MHz which are supposed to have been tested with the MB and be compatible. Although the 4 gigs are detected by the BIOS, I cannot get into windows, I am stuck at the Starting Windows window. When attempting to boot in safe mode, it hangs when trying to load the classpnp.sys driver. I have tried startup repair to no avail and am now turning to you guys to see if anyone has experienced something similar. It is important to note that I have tested both 2gig sticks and they work individually but when brought together in dual channel, windows doesnt want to boot. I have also tried putting them in single channel and it will not work either?

Anyone can help before I attempt a full format to try and solve the driver issues?

thanks
a b $ Windows 7
a b V Motherboard
April 30, 2010 1:40:36 PM

Go into the Bios and manually set the memory to the settings supplied by it's manufacturer.
April 30, 2010 3:27:39 PM

unfortunatly I had already tried that and it did not work. As a test, I took an old XP partition I had on an old IDE drive and it booted up with no problem...I'm starting to think my win7 partition doesnt like this new memory for some odd reason...I have tried all the repairs I could think of and it did not work, I dont really want to format, anyone has any other ideas?

thanks
Related resources
May 1, 2010 1:44:38 AM

UPDATE:

I have tried formatting, flashing my BIOS to the most up to date version, tweaking the voltages and the timings it simply will not work. I have managed to get into windows using the Ballistix DIMMS but it is so unbelievably slow and I cannot figure out why. Booting takes about 5 minutes and once in windows it simply is not bearable. Memory is detected but CPU usage is at 100% at all times. When not doing anything, the processor is split between Explorer and Task Mgr 50/50 for no apparent reason. I simply have no idea what is wrong with those sticks but once again, it seems that using only 1 stick (2 gig total) or using my 2 old sticks for a total of 2 gig aswell works fine but trying to use 2 Ballistix sticks at once for 4 gig, in any DIMM slot combination, simply does not work.


if anyone has any insights let me know before I ship them back. I am afraid of trying out anything else be it another batch or another brand because it seems my board doesnt like anything above 2 gig of ram...


thanks...
a b $ Windows 7
a b V Motherboard
May 1, 2010 2:01:54 AM

The first thing you should do is to run a bootable memory test program such as mem86 to test your memory rather than checking it by seeing if Windows works or not.
May 1, 2010 2:48:47 AM

You did try to boost the ram voltage a bit? have you try a bit more?
May 2, 2010 1:50:47 PM

I tried many voltages and it didnt change anything

I ran memTest with my old DIMMS and it worked fine at a bandwidth of 2900MB/s or so

I tried running it with the Ballistix, it doesnt get any errors but its Awfully slow (10x slower or so than with the old dimms) and yet it indicates a bandwidth of 3700MB/s

I really cant find an explanation for this...
May 3, 2010 1:53:28 AM

so basically,

Memory is dead slow when I use 4 gig even though timings and voltage are adequate (I even tried uping them to see if it made a difference) but is fine when I only use 2.

if anyone has any explanation of what may cause this for this board and this memory I would appreciate your input

thanks
a b $ Windows 7
a b V Motherboard
May 3, 2010 6:58:00 AM

It could be a bug in the BIOS, version 0501 fixed some memory problems so if your BIOS is older than this upgrade your BIOS.
May 3, 2010 1:09:47 PM

Nope, bios is at 0901...
October 3, 2010 2:47:06 AM

Just a bump here, I have the same setup as orig poster, same mobo, same 2 gigs of corasir ram, same bios version and I'm hitting the same problem with win7 64 bit. Comp goes unusably slow with cpu maxed out. Windows does recognize the 4 GB of memory but the comp is essentially unusable. If I swap my old mem in it's all good. I hit up all of my new memory with memtest86+ and it passed with no failures. Any ideas or an update on this?

Also, if I use just one of my new 2GB sticks instead of both of my old 1 GB sticks, win7 works just fine as well. It's only when I get the total memory above 2GB that I have the issue.

Thanks!
!