Sign in with
Sign up | Sign in
Your question
Solved

Need Help with switching over to ahci

Last response: in Storage
Share
September 22, 2011 12:51:05 PM

I am using a msi p67a-gd65 mobo and when it booted it always looked for ide and would find no harddrive i did this sequence
- run regedit.
- go to HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/Msahci
- right-click Start in the Name column, and then click Modify.
- In the Value data box, type 0, and then click OK.
- exit the registry editor.

Then i rebooted the system went into the bios change all three of settings from ide to ahci
http://imageshack.us/photo/my-images/215/screenshotofms...

THe sata marvell 6.0 and the e sata.

THe problem im having is when i start my machine it says no virtual disk the ide message went away and it says no hard disk or something like that but it boots up fine forgive me i am new to this did i need to change all of the settings could i change some back the computer runs very fast now it those messages are annoying im a bit precise in doing things and if you do them right why not. another thing by changing the msahci value from 3 to 0 will that hurt the machine?

More about : switching ahci

a c 375 G Storage
September 22, 2011 2:57:35 PM

1. you should always backup your registry before making changes.

2. The techique you tried to use works on Vista and 7, not XP.

3. I think you forgot to edit a registry key.

http://support.microsoft.com/kb/922976
m
0
l
September 22, 2011 6:48:26 PM

i read the article and it only said to modify the value in the msahci do you know the additional one to edit. I made some pictures to show you what im looking at on startup the screen looks like this



So i went to the bios and this is what it looked like




Is there anything i can do to clean that up do all of those have to be set to ahci i mean your recommendation i am very elementary at this kind of stuff

also more thing if you would not mind looking this is my boot order can you help me fix this for optimum performance




Thanks for all your help my apologizes for the pictures they look a little rough

-andy
m
0
l
Related resources

Best solution

a c 375 G Storage
September 22, 2011 6:55:17 PM

According to the MS document, it states:

To resolve this issue yourself, enable the AHCI driver in the registry before you change the SATA mode of the boot drive. To do this, follow these steps:

Exit all Windows-based programs.
Click Start, type regedit in the Start Search box, and then press ENTER.
If you receive the User Account Control dialog box, click Continue.
Locate and then click one of the following registry subkeys:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IastorV
In the right pane, right-click Start in the Name column, and then click Modify.
In the Value data box, type 0, and then click OK.
On the File menu, click Exit to close Registry Editor.

Notice, 2 keys are listed. Have you tried clicking the "fixit" button to see if it resolves the problem?

The boot order is fine although I like to have my CD/DVD first, then my hard drive.

EDIT
If you aren't using the ESATA ports, disable the ESATA controller in the bios. I think this is why the marvell controller is showing no drives.
Share
September 22, 2011 7:34:26 PM

I will definately try both thanks for all your help i have been wrestling with this problem for months so disable the external sata 6 or the onboard sata 6? i do have a media carder connected will that affect marvell?
m
0
l
September 22, 2011 7:44:37 PM

Success!!!!!!!!!!!!!!! Thank you sir God Bless
m
0
l
a c 375 G Storage
September 22, 2011 8:18:10 PM

Great, glad that worked for you.
m
0
l
September 22, 2011 8:37:32 PM

Best answer selected by xAndyboyx.
m
0
l
!