Sign in with
Sign up | Sign in
Your question

Shared Folder not visible in another PC

Last response: in Networking
Share
November 13, 2009 4:46:51 PM

Hi ! Guys,

I am having problems in setting up shared folders in my LAN.

I have a main PC(A) with direct internet connection which is shared to another PC(B) on a LAN. I have configured internet using ICS as both PC are running on Windows XP. But while sharing files/folders i am having difficulty .

The main PC(A) from which i have shared internet doesn't list its shared folders in "My Network Places" of both PCs .

Whereas, the folders shared by second PC(B) is visible on main PC(A).

+Workgroup computers can't be browsed from PC(B)

Please guide me ?

More about : shared folder visible

November 13, 2009 4:56:43 PM

Sorry for double post .Deleted !
November 13, 2009 5:20:10 PM

aeroman said:
Hi ! Guys,

I am having problems in setting up shared folders in my LAN.

I have a main PC with direct internet connection which is shared to another PC on a LAN. I have configured internet using ICS as both both PC are running on Windows XP. But while sharing files/folders i am having difficulty .

The main PC from which i have shared internet to another PC doesn't list its shared folders in "My Network Places".

Whereas, the folders shared by another PC is visible on main PC.

Please guide me ?



Are both machines in the same workgroup? Can you navigate to the share by UNC path? click start > run and in the open box type \\name of computer sharing\sharename

Is the firewall on the machine in the ICS Machine set to block netbios traffic?

Is File and print sharing enabled for the second adapter through which you share the internet connection? Open your network neighborhood, right click properties that card, in the The connection uses the following items, is File and print sharing there, and have a check box in it?

On that same card, in that same area, highlight TCP/IP and click properties > then click the advanced button > click on the WINS tab and make sure the radio button for default (top choice out of three) Make sure it is not disabled.

Let me know how this goes for you.

BTW, you may want to disable the file and print sharing on your directly connected card if it's not behind a NAT router. You could potentially open your share up to the world like that.

A few last things, right click my computer, choose explore, click on the views tab, scroll to the bottom, do you have simple file sharing enabled or disabled?
and Right click MyComputer, choose manage, expand the system tools, shared folders, and click on shares. Do you see your share there? Lastly make sure the name you gave your share doesn't end with a $ sign If you did, then that would be a hidden share, and you would have to specify it when accessing it.


Related resources
November 13, 2009 5:40:22 PM

Previously both of these PC were connected via a ADSL modem with 2 ports(1 USB,1 ethernet port) in routing mode. Transferring files from one PC to another was taking too long so i decided to reconfigure it.

With these new config i can confirm that both are on a same workgroup.
UNC path isn't accessible on second PC.

Both PCs are using different Internet security suite so i haven't gone through this NetBios traffic thing. Have to check it now.

File & Print Sharing is enabled on both. My ADSL router uses NAPT.

Wins Tab has Default disabled. Its on "Enable NetBios over TCP/IP"


I 'll go through all the settings you have mentioned above and write back later.

Thanks !
November 18, 2009 5:35:31 PM

Thanks ntadmin101 for your detailed guide to fix this thing up.

I have fixed this issue now.

1. I cleared all the old settings first by renaming both Computer Names.

2. Then put both on same workgroup "WORKGROUP".

3. Turned Guest account to "ON" on both PCs.

4. Internet Protocol TCP/IP properties to Assign IP . 192.168.0.xx

5. Then Advanced>WINS tab -> Default

6. Turned Simple FIle Sharing to "ON" in Folder options.

And that's pretty much everything that i've done to fix this issue.

Thanks for all your help. :hello: 



Here's my 2 PC setup pic.
http://www.home-network-help.com/images/simple-ics-network.jpg
November 18, 2009 6:07:46 PM

Any time, brother.. [:wolfen18:9]

Thanks for letting us know that things worked out. Make sure that folder isn't accessible from the Internet.
**Turning on Guest access can have security implications**

in a response to another post, I gave an example of how to map a drive to a machine using a batch file Click here to See that post
November 19, 2009 6:37:39 AM

ntadmin101 said:


Make sure that folder isn't accessible from the Internet.




ntadmin101 ,

How do i check this mate ? :pt1cable: 

In "My Network Places" ;
Folders from PC(A) are listed under "Local Network" while
Folders from PC(B) are listed under "The Internet"

Is this setting OK ?

OR, should i turn Guest account to "OFF" ?
November 20, 2009 1:58:10 PM

I would turn file and print sharing off on the Gateway's Ethernet adapter facing the Internet. If you turn Guest off, then use the logon script shown in the link in my previous response.
!