Sign in with
Sign up | Sign in
Your question

Ethernet Not Working.

Last response: in Networking
Share
November 13, 2009 5:45:27 PM

Hey guys, second post here, so far the help has been great.


Long story short I was sold a faulty hard drive a few weeks ago...Now It got replaced and im up and running it seems.


One very annoying problem tho is that my ethernet is not working. I am currently posting this on the slow as hell wireless connection in my 8 bedroom student house (house mates are hammering the new COD so internet is slow!)


Basically, installed sound and gfx drivers online after format, also supposedly "installed" drivers from MSI website for my Mobo, which said in the readme was essential for PCI, USB etc functions.


Now I know the wire is working as its brand new and I tested it on my girlfriends laptop.

In device manager I have a "?" next to my "ethernet" controller, and it says; The drivers for this device are not installed. (Code 28)

To reinstall the drivers for this device, click Reinstall Driver.

Obviously this is a driver issue...but ive installed it a few times now and its still not working after rebooting..Also no other networks but the wireless one in my connections...Any help would be great, cheers.

More about : ethernet working

November 13, 2009 6:02:30 PM

MackMaster said:
Hey guys, second post here, so far the help has been great.


Long story short I was sold a faulty hard drive a few weeks ago...Now It got replaced and im up and running it seems.


One very annoying problem tho is that my ethernet is not working. I am currently posting this on the slow as hell wireless connection in my 8 bedroom student house (house mates are hammering the new COD so internet is slow!)


Basically, installed sound and gfx drivers online after format, also supposedly "installed" drivers from MSI website for my Mobo, which said in the readme was essential for PCI, USB etc functions.


Now I know the wire is working as its brand new and I tested it on my girlfriends laptop.

In device manager I have a "?" next to my "ethernet" controller, and it says; The drivers for this device are not installed. (Code 28)

To reinstall the drivers for this device, click Reinstall Driver.

Obviously this is a driver issue...but ive installed it a few times now and its still not working after rebooting..Also no other networks but the wireless one in my connections...Any help would be great, cheers.



I apologize for not listing my Mobo.


Its a MSI P965 NEO (problematic as hell by all accounts!)
November 14, 2009 5:00:18 AM

I don't know if you've tried this, but here's the link for the up-to-date mobo drivers.
Related resources
November 15, 2009 2:54:59 PM

H pepperman.


Yes, ive "installed" these drivers on numerous occasions...But to no avail..Everytime I reboot its still the same.
November 15, 2009 3:05:21 PM

[SOLVED]

Thanks for the help..Was a simple case of manually selecting the folder where the drivers were through the new hardware wizard as the "auto" install just didnt work..

Also if anyone else has similar problems. My XP cd is abit scratched, and it "paused" on 3 minutes remaining for about 30 minutes during the install, so I took the cd out and it booted fine..But that may have caused dodgy driver issues.
!