Sign in with
Sign up | Sign in
Your question

Terrible fps with new 9600GT

Last response: in Graphics & Displays
Share
November 10, 2009 10:46:29 PM

i recently installed a new Asus 9600gt and my fps dropped off the chart. The game i play is IL2 Sturmovik 1946 and i cant get more than 15-20 fps! My old card was an ATI Radeon X300 128mb and it ran the game at 60-70 fps. I cant seem to figure out the problem, any help with this would be much appreciated!

More about : terrible fps 9600gt

a b U Graphics card
a b Ĉ ASUS
November 10, 2009 10:52:11 PM

What are your spec's? Please advise so we know what we are working with =)

What model did you buy, the ASUS EN9600GT SILENT or the ASUS EN9600GT?
m
0
l
November 10, 2009 10:56:08 PM

Intel pentium 4 3.00 ghz (Dell 5100 desktop)
2.5 GB ram
Asus EN9600GT
m
0
l
Related resources
November 10, 2009 11:02:43 PM

i have heard of people having similar problems, but it seems to be caused by the newer nvidia drivers. i shall give driver sweeper a go and see if that helps
m
0
l
a c 147 U Graphics card
November 10, 2009 11:15:57 PM

Is the PCI-E power cable plugged in? Are you running any OC software?
m
0
l
a b U Graphics card
a b Ĉ ASUS
November 10, 2009 11:16:19 PM

Make sure you "properly" deleted your old drivers before you install the new ones just like SS suggested. Sometimes if you just delete by going into the ADD/REMOVE programs, you are really leaving a few behind and that is what causes conflicts between drivers.
m
0
l
a b U Graphics card
a b Ĉ ASUS
November 10, 2009 11:21:25 PM

jay2tall said:
Is the PCI-E power cable plugged in? Are you running any OC software?


The model that he has does not use a 6 pin connector. The only one that does use it is the EN9600GT SILENT model.


m
0
l
November 10, 2009 11:23:18 PM

I got rid of the old ATI drivers with driver sweeper but no luck. Also, i am not running any oc software and this model has no PCI-E power cable
m
0
l
a b U Graphics card
a b Ĉ ASUS
November 10, 2009 11:31:50 PM

go into program files and make sure you don't see anything that is related to ati/CCC
m
0
l
November 11, 2009 12:15:12 AM

i got rid of everything ati in my computer except for some .sys and .dll files is my sytem32 folder that "respawn" after being deleted...and driver sweeper cant clean them permanently...
m
0
l
a c 271 U Graphics card
a b Ĉ ASUS
November 11, 2009 12:45:09 AM

gini said:
i got rid of everything ati in my computer except for some .sys and .dll files is my sytem32 folder that "respawn" after being deleted...and driver sweeper cant clean them permanently...

Check the properties of those files, they may be the windows default driver files and as such should not be deleted.
m
0
l
November 11, 2009 12:53:01 AM

yea...im leaving those alone(i think they are impossible to delete anyways)...i cut the in game settings back a notch and now the card has similar fps to what my old one was, still a little miffed that i cant run everything maxed out on such an old game..and so little improvement with such a step up in card quality. I have heard that turning all options in the "manage 3D settings" tab to off will run the game smoother with the "Perfect" in game graphics setting....but wouldnt that kinda defeat the purpose of the graphics card?
m
0
l
!