Sata3 HDD on Sata2 Controller

Hi there, I got a problem which is driving me crazy..

I just got a new WD 500GB Caviar Black Sata3 HDD and plugged it on my Gigabyte MA790GP-UD4H 's Sata2 controller..
Now the problem is that the raid controller recognize the disk as Sata1 (1.5Gbps)...
Then I tried a couple of jumpers from a very old disk to short-circuit the 5 and 6 pins to limit down the HDD to Sata2 (3Gbps) as the HDD indicates but to find out that this doesn't work either..
The mobo's latest bios version is installed, and I even tried different cables onto different ports to no avail..

I'm desperate at the moment and I would be thankfull for any tips or advices that you can give me..
I've waited this HDD for almost a month...


Thanks in advance.
4 answers Last reply
More about sata3 sata2 controller
  1. Have you updated your motherboard to the latest BIOS?
    http://www.gigabyte.com/products/product-page.aspx?pid=3003#bios

    None of the BIOS changelogs refer to SATA, but it's worth a try.
  2. fzabkar said:
    Have you updated your motherboard to the latest BIOS?
    http://www.gigabyte.com/products/product-page.aspx?pid=3003#bios

    None of the BIOS changelogs refer to SATA, but it's worth a try.



    Yes, I already wrote about that, but thanks for the answer anyway..
  3. Btw, I did a quick installation and ran a test with CrystalDiskMark.

    Raid 0
    1x WD Caviar Black 500GB Sata2 recognized as Sata2(3Gbps)
    1x WD Caviar Black 500GB Sata3 recognized as Sata1(1.5Gbps)


    http://s3.postimage.org/1b1muovr8/Bench.jpg


    *For an unknown reason I couldn't edit my previous post oO
  4. Sorry, I should have read your post more closely.

    Your results are indeed strange. I'm wondering whether there is a firmware problem at the drive end.

    That said, I doubt that you would notice any performance degradation, at least not in the sustained data transfer rate.
Ask a new question

Read More

Hard Drives Western Digital Controller Storage