9800gt physx

OK, so I broke down and purchased a PNY 9800gt, Good card, I like it, performs well. However, In the nvidia setup I have checked the box to enable physx on the gpu but when I start a game, Batman AA to be exact, the on screen display says physx>cpu. Why would it be using the cpu for physx if I have enabled it to use the GPU?
7 answers Last reply
More about 9800gt physx
  1. I believe the PhysX set up in Batman AA requires a second nvidia card dedicated to PhysX in order to not default to CPU. It is a source of considerable controversy atm.
  2. to have the PhysX on the batman you need another card.......................................wat is the spec of yur CPU
  3. JofaMang said:
    I believe the PhysX set up in Batman AA requires a second nvidia card dedicated to PhysX in order to not default to CPU. It is a source of considerable controversy atm.


    so 1 geforce card alone like single GTX260 will be not enough to run PhysX in batman AA? could you please give link regarding this matter? :??:
  4. The use of PhysX on a single card artificially cripples the performance significantly. Read the tom's review of Batman AA and do some googling, it is well known enough that I am not gonna waste my time diggin up links, when you can use that time to answer the question for yourself.
  5. JofaMang said:
    The use of PhysX on a single card artificially cripples the performance significantly. Read the tom's review of Batman AA and do some googling, it is well known enough that I am not gonna waste my time diggin up links, when you can use that time to answer the question for yourself.


    LOL i forgot tom's made some article about batman AA. thanks man :D
  6. Sorry Im so late to reply. Well, I guess that pretty much clears things up for me; a single physx card is useless, at least with Batman AA. Not a big deal I guess seeing as how the 9800 is still leaps and bounds better than the HD3450 I was using :) . My CPU is an AMD athlon 64 x2 5000 brisbane. Furthermore, if the physx is going to hurt my performance when playing Batman AA, where/how can I disable pysx entirely? I do not see the option in the game's menu nor in the nvidia control panel. All I can see is where i can tell it to use the cpu or gpu.
  7. Actually, the 1.1 patch enabled me to enable physx and it works just fine. Who knew.
Ask a new question

Read More

Graphics Cards GPUs Physx CPUs Graphics