Sign in with
Sign up | Sign in
Your question

DVI to HDMI.Radeon HD 4770 no sound when play HD

Last response: in Graphics & Displays
Share
November 12, 2009 7:12:51 AM

Hi,

Recently i bought my HP LP2475W 24" and has been connected to my PC's Radeon HIS HD4770(to DVI ports) DDVI to HDMI to monitors HDMI. Problem is there is no sound when HD played on PC.My speakers are plugged into my PC and they work whenever i do listen to music or play movie, youtube and so on but the HD download. On my windows player i can see red cross , click on it and it says no error-missing codec. Well i have couple of media players but all of them don't produce a single sound when HD played. ???Thank you P.S. Using windows vista 64 bit.
a b U Graphics card
November 12, 2009 9:09:18 AM

You are identifying two different possible problems.

You have to set your sound device to ATI's HDMI audio. The drivers would have been installed with the rest of the video card drivers, unless you opted out. Your 4770 has it's own sound card built into it, to use HDMI output, you have to make sure the computer is using it.
November 12, 2009 9:20:37 AM

In my sound manager option i looked and found that HDMI audio is set up(if that what you ment) i did updated my ati drivers as well just to make sure i have up to date ones. Another interesting thing is: volume bar is moving while playing HD video!!!!
Related resources
November 12, 2009 9:41:54 AM

nebulaoperator said:
In my sound manager option i looked and found that HDMI audio is set up(if that what you ment) i did updated my ati drivers as well just to make sure i have up to date ones. Another interesting thing is: volume bar is moving while playing HD video!!!!

Go to Control panel -> Audio options and select your normal sound card as default.
Eventually problem can be in player that can override audio settings.

You don't want to use HDMI as audio source unless you have AV receiver connected to your graphic card thru HDMI.

In my system i have currently 3 audio cards, HDMI (graphic card), digital audio (integrated on board) and Xi-fi i am using.
It sometime get little messy as which one is used.
a b U Graphics card
November 12, 2009 9:46:23 AM

I took it from his description that he wants to use the speakers in his monitor, which would be treated no differenty from within the computer settings than an AV reciever.
November 12, 2009 10:33:14 AM

Just to clarify some details.My monitor does not have in built a speakers I use external ones. By the way i am at the moment at work so using different pc( which has windows xp) and on this OS i can not find what xrodney suggested:
Go to Control panel -> Audio options and select your normal sound card as default. I mean sound card as option is not found by me?! Thank you
November 12, 2009 11:41:45 AM

xrodney said:
Go to Control panel -> Audio options and select your normal sound card as default.
Eventually problem can be in player that can override audio settings.

You don't want to use HDMI as audio source unless you have AV receiver connected to your graphic card thru HDMI.

In my system i have currently 3 audio cards, HDMI (graphic card), digital audio (integrated on board) and Xi-fi i am using.
It sometime get little messy as which one is used.

Just to clarify some details.My monitor does not have in built a speakers I use external ones. By the way i am at the moment at work so using different pc( which has windows xp) and on this OS i can not find what xrodney suggested:
Go to Control panel -> Audio options and select your normal sound card as default. I mean sound card as option is not found by me?! Thank you

November 12, 2009 4:18:40 PM

Thank you to everyone.Went back home and found those settings on my vista PC. Sound is working:) 
!