Sign in with
Sign up | Sign in
Your question
Solved

Updating BIOS breaks on-board NIC?

Tags:
  • Chipsets
  • BIOS
  • Motherboards
Last response: in Motherboards
Share
a c 229 V Motherboard
May 4, 2010 8:09:59 PM

Greetings,

Recently, I updated the BIOS of my Gigabyte GA-MA790X-UD4P motherboard based system to the latest version in anticipation of installing a new Phenom X6 CPU (arrives today). All went well until I restarted the system (Qflash indicated successful upgrade).

When the system restarted (Win7 x64 Ult), the on-board Realtek based network adapter, which had worked under the previous BIOS, could not "see" the network. After messing with it for about an hour, I simply deactivated the device in the BIOS and uninstalled the drivers, while installing a discrete NIC.

I am a VERY experienced PC builder and tech and I have never experienced this before. Any ideas beyond checking BIOS settings and re-installing drivers (did all that)?

Have a HOOAH day!!!

v/r
JAE

More about : updating bios breaks board nic

Best solution

a b V Motherboard
May 4, 2010 8:57:00 PM

The Gigabyte GA-MA790X-UD4P. Perhaps the finest AM2+ board ever made. :) 

Did the Operating system come from another machine? I have only seen this behavior in a windows install that came from another machine without a repair install. It worked fine for more than a year and then the NIC started acting up. Nothing fixed it except a OS reinstall.

So I would boot off another OS somehow. New hard drive or bood cd like Linux or BART and see if your issue is OS or hardware.

If you get it working with another os source, then its likely the os so try a repair install.

If you cant get it to work with another OS source, try reflashing the old bios and see if their is a bug in the new F10a bios. They just release it, so it may be a bug that slipped past Gigabyte.

Another possibility is the NIC just took a dive on you. But I dont think thats likely.



I
Share
a c 229 V Motherboard
May 4, 2010 11:56:24 PM

Agreed on the quality of the board. It is indeed one of the best I have ever used. Great suggestion on the use of an alternate OS. Will try and report results. The OS did not come from another system. The current install is the one and only.

Something odd (I forgot to include in my original post) did happen last night. Win7 forced me to re-activate the install based on a hardware change. Since I only "swapped" NICs, I was a bit surprised (especially since I had to do the manual method as opposed to working on-line). Seems that the BIOS upgrade triggered a response.

Regardless, still a great board. Will keep the group posted.

HOOAH!!!
m
0
l
Related resources
a b V Motherboard
May 5, 2010 1:35:58 AM

I'm surprised a NIC triggered that. Don't think its related to the problem though.

Did you get the 1090t or the 1055t?
m
0
l
a c 229 V Motherboard
May 5, 2010 2:41:34 AM

I just installed the 1090t. I also reactivated the on-board NIC. I reloaded all Win7 Realtek drivers. Now all is working and I wasn't forced into a reactivation cycle. Odd as heck, but all seems well. Going to crunch some numbers and shake her now. So far, so good. Just can't explain it.....
m
0
l
a b V Motherboard
May 5, 2010 6:00:25 AM

I'm glad it worked out. Let us know how the 1090 works for you. I haven't seen a whole lot on how it performs in AM2+ boards and I have the same board you have.
m
0
l
a c 229 V Motherboard
May 5, 2010 12:39:24 PM

Overnight "burn in" provided no surprises. System is stable. Going from a Phenom II 965 BE to the Phenom II X6 1090T BE I can tell very little difference. The 965 actually has a higher clock speed and scores slightly higher than the 1090T with the Win7 benchmarking tool.

Over the next few days, I will subject the system to multiple benchmarking apps. If I see anything interesting, I will report back.

BTW, all of my games seem "smoother" with the X6 vice the X4. Not something I can quantify at this point, just a feel kind of thing.

Happy so far (but the whole NIC/re-activate thing is bugging my inner geek). HOOAH!!!
m
0
l
a c 229 V Motherboard
May 15, 2010 2:30:23 AM

Best answer selected by COLGeek.
m
0
l
!