Can't reconnect external WD hard drive

Hi
I recently moved my computer and when reconnected I could not use external hard drive.I keep getting the message that I need to format disk.It used to recognise it as F drive and now it is G.It will not allow me to format and I'm sure there is a simple solution but I am pretty clueless.Any help would be much appreciated as I need to back up and can't
6 answers Last reply
More about reconnect external hard drive
  1. I see this occasionally with but only with my PC's front USB ports as they have seen the most use and are on the way out, see if you get the message using the rear ports
  2. nope tried it and it made no difference.
  3. Go to disk management. Right Click on My Computer and choose "Manage" to get there.

    You need to assign a drive letter to this disk and it will come up as the same letter every time. If it doesn't show up as formatted there, then you can right-click and do it there.
  4. It already has has drive G assigned and tried to format as instructed and it does not allow.thanks for trying
  5. Did you dismount before attempting to format? If it shows up on Disk Managment, you can format it.

    If you can't, it's because you're doing it wrong...unless there's some kind of error during formatting that you aren't telling me about.
  6. I have had this problem by not ejecting drives and just unplugging them. Have you tried this drive in another computer?
    -Bruce
    http://answers.microsoft.com/en-us/windows/forum/windows_vista-system/you-need-to-format-the-disk-in-drive-j-before-you/4e153784-3217-4425-9c39-48030af82a13 look at the last post and try the partition tool.
Ask a new question

Read More

Hard Drives Western Digital External Hard Drive Storage